# CVE-2026-101915: @grpc/grpc-js: The server transmits some error messages thrown by method handlers to the client in status messages

> Attackers can obtain sensitive information from error messages returned by gRPC server method handlers in the @grpc/grpc-js library.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 1 Oct 2026
- **Also known as:** CLEANSTART-2026-AF37624, CLEANSTART-2026-DP81887, CLEANSTART-2026-VD98265, CLEANSTART-2026-ZH62940, ECHO-2e1d-24f0-0a19, GHSA-f596-whhp-79r4, MINI-2fxm-4rv5-wfwq, MINI-4jg6-7mmp-64x9, MINI-57rr-gjxc-h4f8, MINI-76x8-m9hg-pcr4, MINI-8cfg-gqc6-fhcj, MINI-985w-82vm-2j62, MINI-c34v-6r6g-pm8r, MINI-f3hf-p7jh-wqw4, MINI-f8rf-gj5w-46w9, MINI-gpr6-7vh7-w695, MINI-h8v5-93w6-7h4x, MINI-m3qm-pj99-hm2c, MINI-rj7h-25wp-vv72, MINI-vpq7-65q4-xhj6, MINI-w365-3cv3-wc9w

## What is CVE-2026-101915?

CVE-2026-101915 is a low-severity vulnerability in grpc-node, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@grpc/grpc-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.13.6 and 1.14.5, when an application method handler throws an uncaught error, the server includes its error message in the status message sent to the client. The thrown error message is transmitted to the client, causing sensitive information disclosure when the message contains sensitive data. This issue is fixed in versions 1.13.6 and 1.14.5.

Weakness: CWE-550 (Server-generated Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-101915?

4 open source packages ship an affected version, including @grpc/grpc-js.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@grpc/grpc-js` | npm | All versions | 1.13.6 |
| `@grpc/grpc-js` | npm | All versions | 1.13.6 |
| `@grpc/grpc-js` | npm | From 1.14.0 | 1.14.5 |
| `@grpc/grpc-js` | npm | From 1.14.0 | 1.14.5 |

## How do I fix CVE-2026-101915?

Upgrade @grpc/grpc-js to a fixed version for your release line: 1.13.6 or 1.14.5.

## Is CVE-2026-101915 being exploited?

There is no known exploitation of CVE-2026-101915 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101915 and fix it if it is affected.

What it is: CVE-2026-101915 is a low-severity vulnerability in grpc-node, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-101915 in the wild and no public exploit code.

Affected packages and fixed versions:
- @grpc/grpc-js (npm): affected all versions; fixed in 1.13.6
- @grpc/grpc-js (npm): affected all versions; fixed in 1.13.6
- @grpc/grpc-js (npm): affected from 1.14.0; fixed in 1.14.5
- @grpc/grpc-js (npm): affected from 1.14.0; fixed in 1.14.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101915/ (Markdown: https://insights.sbomify.com/CVE-2026-101915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101915
- OSV: https://osv.dev/vulnerability/CVE-2026-101915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101915/
Summaries are generated and may contain mistakes; the official description above is the record.
