# CVE-2026-101917: PyJWT: PyJWKClient still amplifies unauthenticated JWKS fetches on unknown kid values (incomplete fix of CVE-2026-48524)

> Attackers can cause denial of service by amplifying outbound requests to JWKS endpoints via unknown key IDs in PyJWT.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** AZL-104982, CLEANSTART-2026-QR87061, CLEANSTART-2026-UK80240, DEBIAN-CVE-2026-101917, ECHO-4350-3a06-160e, GHSA-2gx3-rcp4-g85q, MINI-246f-349m-gfcm, MINI-24j3-qf3x-x6hc, MINI-27cc-777w-2wfh, MINI-2f5v-9254-8xwg, MINI-2xgp-4r4x-wqxf, MINI-454r-vqfg-cq3x, MINI-4vxx-5hfc-3657, MINI-5mfm-rqww-hqcm, MINI-5x7p-4v95-3j9r, MINI-6hm6-m22p-cr39, MINI-73wf-7hqf-cr42, MINI-7xpm-956c-xg6m, MINI-85cm-4wfv-63mr, MINI-9r4h-5xww-rhhf, MINI-9rcr-744f-frv9, MINI-c32j-mp42-5xj7, MINI-c5m8-pq4c-fhrg, MINI-g8m3-3x83-8mh7, MINI-p7v7-rvfp-4rph, MINI-q8cj-mq3r-7qw9, MINI-r447-whpw-w2w9, MINI-v9qm-jrx4-9p68, MINI-vrp4-9g69-5996, MINI-w5vc-648g-gfrq, MINI-x9w3-97jw-6m39, PYSEC-2026-4140, UBUNTU-CVE-2026-101917

## What is CVE-2026-101917?

CVE-2026-101917 is a medium-severity denial of service vulnerability in jpadilla pyjwt, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, PyJWT get_signing_key_from_jwt is affected because unknown kid misses force refreshes without a negative cache or minimum refresh interval. This occurs when unauthenticated tokens repeatedly use the same unknown kid or varying kid values absent from the cached JWKS. As a result, each cache miss causes PyJWKClient to refresh the JWKS. Consequently, attacker traffic can amplify outbound requests to the configured JWKS endpoint. This issue is fixed in version 2.14.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-101917?

3 open source packages ship an affected version, including pyjwt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyjwt` | PyPI | All versions | 2.14.0 |
| `pyjwt` | PyPI | All versions | 2.14.0 |
| `pyjwt` | PyPI | All versions | 2.14.0 |

Products: Pyjwt Project Pyjwt.

## How do I fix CVE-2026-101917?

Upgrade pyjwt to 2.14.0 or later.

## Is CVE-2026-101917 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101917 exists.

## Other vulnerabilities in jpadilla pyjwt

- [CVE-2026-102268](https://insights.sbomify.com/CVE-2026-102268/): PyJWT: Asymmetric-PEM detection bypass: whitespace/line-ending-mutated public keys skip the HS/asymmetric confusion guard (critical 9.1)
- [CVE-2026-32597](https://insights.sbomify.com/CVE-2026-32597/): PyJWT accepts unknown `crit` header extensions (RFC 7515 §4.1.11 MUST violation) (high 7.5)
- [CVE-2026-102266](https://insights.sbomify.com/CVE-2026-102266/): PyJWK accepts empty HMAC keys, bypassing PyJWT's empty-key validation (high 7.4)
- [CVE-2026-102267](https://insights.sbomify.com/CVE-2026-102267/): PyJWT: PyJWKClient follows redirects when fetching JWKS (high 7.4)
- [CVE-2026-102271](https://insights.sbomify.com/CVE-2026-102271/): PyJWT: Public keys in DER form are accepted as HMAC secrets, bypassing the CVE-2022-29217 guard (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101917 and fix it if it is affected.

What it is: CVE-2026-101917 is a medium-severity denial of service vulnerability in jpadilla pyjwt, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101917 exists.

Affected packages and fixed versions:
- pyjwt (PyPI): affected all versions; fixed in 2.14.0
- pyjwt (PyPI): affected all versions; fixed in 2.14.0
- pyjwt (PyPI): affected all versions; fixed in 2.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101917/ (Markdown: https://insights.sbomify.com/CVE-2026-101917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101917
- OSV: https://osv.dev/vulnerability/CVE-2026-101917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101917/
Summaries are generated and may contain mistakes; the official description above is the record.
