# CVE-2026-101918: PyJWT: Unauthenticated RecursionError DoS in pre-verification payload parse (PyJWKClient.get_signing_key_from_jwt / verify_signature=False)

> An unauthenticated attacker can cause a denial of service by sending a recursively nested JWT payload that triggers an unhandled RecursionError in PyJWT.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** AZL-105218, CLEANSTART-2026-VH40017, CLEANSTART-2026-YK12318, DEBIAN-CVE-2026-101918, ECHO-0875-60f2-86d9, GHSA-42vr-xj54-vc7v, MINI-6855-hxgf-7xg6, MINI-6mfr-vpwg-cq5g, MINI-74vg-498w-r56c, MINI-86jw-vvhr-xjh9, MINI-9wp4-qrxq-74qm, MINI-9x2x-g45v-cj93, MINI-c7q9-4vm9-vr49, MINI-cgjf-g7vh-ff2c, MINI-g9m4-pgwf-9xgp, MINI-gxch-78pm-hq89, MINI-h89v-3gf3-2h47, MINI-hwhr-g43j-r2qm, MINI-m8p3-5v29-wh88, MINI-mfcx-mwhg-65gw, MINI-q72w-vhf5-c5wr, MINI-q958-ppw6-6cg3, MINI-qr5f-jpqc-jh8g, MINI-r59j-8882-7fm3, MINI-r6g3-rhmj-m2pr, MINI-v3jm-fw2m-4r5f, MINI-v6r8-h8v7-rfvg, MINI-x4cj-8qv5-6845, MINI-x6hw-4h3m-fqrj, MINI-xvc7-77w5-rr5g, PYSEC-2026-4141, UBUNTU-CVE-2026-101918

## What is CVE-2026-101918?

CVE-2026-101918 is a medium-severity denial of service vulnerability in jpadilla pyjwt, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PyJWT is a Python implementation of JSON Web Token standards. From 2.0.0a1 until 2.15.0, PyJWT PyJWKClient.get_signing_key_from_jwt is affected because payload parser catches ValueError but not RecursionError. This occurs when an attacker-controlled recursively nested payload reaches json.loads. As a result, documented PyJWT exception handling does not contain the failure. Consequently, an unauthenticated request can raise an exception that may produce an HTTP 500 response. The advisory-defined affected implementation also includes jwt/api_jwt.py, verify_signature=False. This issue is fixed in version 2.15.0.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-101918?

3 open source packages ship an affected version, including pyjwt and PyJWT. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyjwt` | PyPI | From 2.0.0a1 | 2.15.0 |
| `pyjwt` | PyPI | From 2.0.0a1 | 2.15.0 |
| `PyJWT` | PyPI | From 2.0.0a1 | 2.15.0 |

Products: Pyjwt Project Pyjwt.

## How do I fix CVE-2026-101918?

Upgrade pyjwt to 2.15.0 or later.

## Is CVE-2026-101918 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101918 exists.

## Other vulnerabilities in jpadilla pyjwt

- [CVE-2026-102268](https://insights.sbomify.com/CVE-2026-102268/): PyJWT: Asymmetric-PEM detection bypass: whitespace/line-ending-mutated public keys skip the HS/asymmetric confusion guard (critical 9.1)
- [CVE-2026-32597](https://insights.sbomify.com/CVE-2026-32597/): PyJWT accepts unknown `crit` header extensions (RFC 7515 §4.1.11 MUST violation) (high 7.5)
- [CVE-2026-102266](https://insights.sbomify.com/CVE-2026-102266/): PyJWK accepts empty HMAC keys, bypassing PyJWT's empty-key validation (high 7.4)
- [CVE-2026-102267](https://insights.sbomify.com/CVE-2026-102267/): PyJWT: PyJWKClient follows redirects when fetching JWKS (high 7.4)
- [CVE-2026-102271](https://insights.sbomify.com/CVE-2026-102271/): PyJWT: Public keys in DER form are accepted as HMAC secrets, bypassing the CVE-2022-29217 guard (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101918 and fix it if it is affected.

What it is: CVE-2026-101918 is a medium-severity denial of service vulnerability in jpadilla pyjwt, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101918 exists.

Affected packages and fixed versions:
- pyjwt (PyPI): affected from 2.0.0a1; fixed in 2.15.0
- pyjwt (PyPI): affected from 2.0.0a1; fixed in 2.15.0
- PyJWT (PyPI): affected from 2.0.0a1; fixed in 2.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101918/ (Markdown: https://insights.sbomify.com/CVE-2026-101918/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101918
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101918
- OSV: https://osv.dev/vulnerability/CVE-2026-101918

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101918/
Summaries are generated and may contain mistakes; the official description above is the record.
