# CVE-2026-10196: Mail Mint <= 1.31.0 - Unauthenticated PHP Object Injection in Arbitrary Form Fields

> Unauthenticated attackers can achieve remote code execution via PHP object injection in the Mail Mint WordPress plugin.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 5 Sep 2026
- **Updated:** 7 Sep 2026
- **Also known as:** GHSA-v38w-pf7m-c3pr

## What is CVE-2026-10196?

CVE-2026-10196 is a critical unsafe deserialization vulnerability in getwpfunnels Mail Mint – Email Marketing, Newsletter, Email Automation & WooCommerce Emails, published on 5 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Mail Mint – Email Marketing, Newsletter, Email Automation & WooCommerce Emails plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.31.0 via deserialization of untrusted input in the 'handle_form_submission' function. This makes it possible for unauthenticated attackers to inject a PHP Object. The additional presence of a POP chain allows attackers to execute code on the server. The vulnerability was partially patched in version 1.23.1.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-10196?


## How do I fix CVE-2026-10196?

No fix has been published for CVE-2026-10196 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-10196 being exploited?

There is no known exploitation of CVE-2026-10196 in the wild and no public exploit code.

Public exploit code:

- https://github.com/0xCyp1337/CVE-2026-10196 (github_poc): https://github.com/0xCyp1337/CVE-2026-10196

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-10196 and fix it if it is affected.

What it is: CVE-2026-10196 is a critical unsafe deserialization vulnerability in getwpfunnels Mail Mint – Email Marketing, Newsletter, Email Automation & WooCommerce Emails, published on 5 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-10196 in the wild and no public exploit code.

Affected product: getwpfunnels Mail Mint – Email Marketing, Newsletter, Email Automation & WooCommerce Emails. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-10196/ (Markdown: https://insights.sbomify.com/CVE-2026-10196/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-10196
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-10196
- OSV: https://osv.dev/vulnerability/CVE-2026-10196

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-10196/
Summaries are generated and may contain mistakes; the official description above is the record.
