# CVE-2026-102005: VxWorks Memory Allocation

> A memory leak in VxWorks under non-default configurations can cause system termination, requiring an upgrade to resolve.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-rgq7-v7jf-59g9

## What is CVE-2026-102005?

CVE-2026-102005 is a medium-severity denial of service vulnerability in Wind River Inc VxWorks 7, published on 28 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Wind River VxWorks 7 24.03 through 26.03, a memory leak occurs under specific, non-default configuration states when processing specific service routines, causing the system to terminate operations before releasing allocated memory pools. Fixed in VxWorks 7 26.09

Weakness: CWE-401 (Missing Release of Memory after Effective Lifetime)

## Which versions are affected by CVE-2026-102005?


## How do I fix CVE-2026-102005?

No fix has been published for CVE-2026-102005 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-102005 being exploited?

There is no known exploitation of CVE-2026-102005 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102005 and fix it if it is affected.

What it is: CVE-2026-102005 is a medium-severity denial of service vulnerability in Wind River Inc VxWorks 7, published on 28 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102005 in the wild and no public exploit code.

Affected product: Wind River Inc VxWorks 7. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102005/ (Markdown: https://insights.sbomify.com/CVE-2026-102005/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102005
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102005
- OSV: https://osv.dev/vulnerability/CVE-2026-102005

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102005/
Summaries are generated and may contain mistakes; the official description above is the record.
