# CVE-2026-10223: NousResearch hermes-agent memory_tool.py _scan_memory_content injection

> Remote attackers can execute arbitrary code via injection in the hermes-agent memory scanning function, requiring immediate mitigation due to public exploit availability.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 1 Jun 2026
- **Also known as:** GHSA-33qv-c5qm-799v, PYSEC-2026-3575

## What is CVE-2026-10223?

CVE-2026-10223 is a medium-severity code injection vulnerability in NousResearch hermes-agent, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A weakness has been identified in NousResearch hermes-agent up to 2026.4.30. This affects the function _scan_memory_content of the file tools/memory_tool.py. This manipulation causes injection. The attack can be initiated remotely. The exploit has been made available to the public and could be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2026-10223?

3 open source packages ship an affected version, including hermes-agent.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hermes-agent` | PyPI | All versions | 0.15.0 |
| `hermes-agent` | PyPI | All versions | 0.15.0 |
| `hermes-agent` | PyPI | All versions | 0.15.0 |

## How do I fix CVE-2026-10223?

Upgrade hermes-agent to 0.15.0 or later.

## Is CVE-2026-10223 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10223 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-10223 and fix it if it is affected.

What it is: CVE-2026-10223 is a medium-severity code injection vulnerability in NousResearch hermes-agent, published on 1 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10223 exists.

Affected packages and fixed versions:
- hermes-agent (PyPI): affected all versions; fixed in 0.15.0
- hermes-agent (PyPI): affected all versions; fixed in 0.15.0
- hermes-agent (PyPI): affected all versions; fixed in 0.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-10223/ (Markdown: https://insights.sbomify.com/CVE-2026-10223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-10223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-10223
- OSV: https://osv.dev/vulnerability/CVE-2026-10223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-10223/
Summaries are generated and may contain mistakes; the official description above is the record.
