# CVE-2026-102267: PyJWT: PyJWKClient follows redirects when fetching JWKS

> Attackers can exploit redirect handling in PyJWKClient to disclose credentials or substitute verification keys when trusted endpoints return malicious redirects.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 1 Oct 2026
- **Also known as:** AZL-104979, CLEANSTART-2026-GM98203, CLEANSTART-2026-IE39566, DEBIAN-CVE-2026-102267, ECHO-669e-7f60-f638, GHSA-9v7f-9g4p-ffgj, MINI-2pc6-24cw-qgqq, MINI-323w-5cm2-2v22, MINI-4237-qf2f-x5f9, MINI-46v7-v622-9739, MINI-53q9-p75r-hvjp, MINI-6wg4-93h5-qqv4, MINI-7867-g78r-m63q, MINI-7gvv-6vjx-9m8w, MINI-7r27-r3q6-4ww9, MINI-85hp-v396-23hm, MINI-9586-59gj-vpqv, MINI-g539-9jv4-57wv, MINI-gg26-c48c-vxv5, MINI-gqq9-33w5-6rm5, MINI-hqw9-vh3q-hjj2, MINI-m272-9j9j-3mwp, MINI-mm3x-gm2x-74m9, MINI-q9wm-6h29-c3v9, MINI-qwcx-3fv4-wj7m, MINI-r4v8-6c3w-37fj, MINI-r6g4-32vj-gqg8, MINI-vxh4-j6ch-jv4c, MINI-wq4g-qppg-cm6v, MINI-wx9w-jrp3-c4cg, MINI-xwf6-m7f3-g92w, PYSEC-2026-4144, ROOT-APP-PYPI-CVE-2026-102267, UBUNTU-CVE-2026-102267

## What is CVE-2026-102267?

CVE-2026-102267 is a high-severity server-side request forgery vulnerability in jpadilla pyjwt, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, PyJWT PyJWKClient is affected because redirect destinations are not revalidated against the JWKS trust boundary. This occurs when a configured trusted JWKS endpoint returns an attacker-influenced redirect. As a result, PyJWKClient follows the redirect and consumes the redirected response as key material. Consequently, forwarded credentials may be disclosed or verification keys may be substituted. This issue is fixed in version 2.14.0.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-345 (Insufficient Verification of Data Authenticity), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-102267?

3 open source packages ship an affected version, including pyjwt and PyJWT. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyjwt` | PyPI | All versions | 2.14.0 |
| `pyjwt` | PyPI | All versions | 2.14.0 |
| `PyJWT` | PyPI | All versions | 2.14.0 |

Products: Pyjwt Project Pyjwt.

## How do I fix CVE-2026-102267?

Upgrade pyjwt to 2.14.0 or later.

## Is CVE-2026-102267 being exploited?

There is no known exploitation of CVE-2026-102267 in the wild and no public exploit code.

## Other vulnerabilities in jpadilla pyjwt

- [CVE-2026-102268](https://insights.sbomify.com/CVE-2026-102268/): PyJWT: Asymmetric-PEM detection bypass: whitespace/line-ending-mutated public keys skip the HS/asymmetric confusion guard (critical 9.1)
- [CVE-2026-32597](https://insights.sbomify.com/CVE-2026-32597/): PyJWT accepts unknown `crit` header extensions (RFC 7515 §4.1.11 MUST violation) (high 7.5)
- [CVE-2026-102266](https://insights.sbomify.com/CVE-2026-102266/): PyJWK accepts empty HMAC keys, bypassing PyJWT's empty-key validation (high 7.4)
- [CVE-2026-102271](https://insights.sbomify.com/CVE-2026-102271/): PyJWT: Public keys in DER form are accepted as HMAC secrets, bypassing the CVE-2022-29217 guard (high 7.4)
- [CVE-2026-102272](https://insights.sbomify.com/CVE-2026-102272/): PyJWT BOM Bypass (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102267 and fix it if it is affected.

What it is: CVE-2026-102267 is a high-severity server-side request forgery vulnerability in jpadilla pyjwt, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102267 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyjwt (PyPI): affected all versions; fixed in 2.14.0
- pyjwt (PyPI): affected all versions; fixed in 2.14.0
- PyJWT (PyPI): affected all versions; fixed in 2.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102267/ (Markdown: https://insights.sbomify.com/CVE-2026-102267/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102267
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102267
- OSV: https://osv.dev/vulnerability/CVE-2026-102267

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102267/
Summaries are generated and may contain mistakes; the official description above is the record.
