# CVE-2026-102269: PyJWT: Non-canonical signature segments enable raw-token revocation bypass

> Attackers can bypass raw-token revocation checks in PyJWT by using non-canonical Base64URL characters in the signature segment.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** AZL-104985, CLEANSTART-2026-CG08650, CLEANSTART-2026-DL13850, DEBIAN-CVE-2026-102269, ECHO-737a-6d67-3fbf, GHSA-hxm8-2xgr-2p9m, MINI-2884-pgh7-x7w4, MINI-2hg4-ww2c-j927, MINI-3r82-g5jv-fpjw, MINI-45qm-hrcr-x8w4, MINI-4mhg-69w9-5jj9, MINI-6fv4-hj4p-rrx2, MINI-7394-92pq-553m, MINI-9439-23cv-4pcj, MINI-cvxg-vxv8-6fgv, MINI-ff54-47vr-58w2, MINI-fjwm-gm38-4pwp, MINI-fm96-88j8-mxw4, MINI-fw72-vqf6-h3cf, MINI-g6j3-jff9-vppc, MINI-gf54-49f2-535w, MINI-gqqj-2wp9-fgmf, MINI-h3x9-6m6w-rr2p, MINI-j59p-v623-7c2p, MINI-jcr7-gjj2-vpq3, MINI-jrwp-x65j-vrc7, MINI-pr58-3xhg-q378, MINI-qmqh-8mf4-3gxh, MINI-w4cw-9f7h-7375, MINI-x4vr-4444-m8pv, MINI-x6q8-3crw-hccc, PYSEC-2026-4147, UBUNTU-CVE-2026-102269

## What is CVE-2026-102269?

CVE-2026-102269 is a medium-severity vulnerability in jpadilla pyjwt, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, PyJWT signature segment is affected because signature segment decoding accepts characters outside the canonical Base64URL representation. This occurs when non-Base64URL characters are appended to a valid compact JWS signature segment. As a result, base64url_decode produces the same signature bytes for different serialized segments. Consequently, raw-token revocation checks can fail to recognize an equivalent modified token. This issue is fixed in version 2.14.0.

Weakness: CWE-180 (Incorrect Behavior Order: Validate Before Canonicalize)

## Which versions are affected by CVE-2026-102269?

3 open source packages ship an affected version, including pyjwt and PyJWT. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyjwt` | PyPI | All versions | 2.14.0 |
| `pyjwt` | PyPI | All versions | 2.14.0 |
| `PyJWT` | PyPI | All versions | 2.14.0 |

Products: Pyjwt Project Pyjwt.

## How do I fix CVE-2026-102269?

Upgrade pyjwt to 2.14.0 or later.

## Is CVE-2026-102269 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102269 exists.

## Other vulnerabilities in jpadilla pyjwt

- [CVE-2026-102268](https://insights.sbomify.com/CVE-2026-102268/): PyJWT: Asymmetric-PEM detection bypass: whitespace/line-ending-mutated public keys skip the HS/asymmetric confusion guard (critical 9.1)
- [CVE-2026-32597](https://insights.sbomify.com/CVE-2026-32597/): PyJWT accepts unknown `crit` header extensions (RFC 7515 §4.1.11 MUST violation) (high 7.5)
- [CVE-2026-102266](https://insights.sbomify.com/CVE-2026-102266/): PyJWK accepts empty HMAC keys, bypassing PyJWT's empty-key validation (high 7.4)
- [CVE-2026-102267](https://insights.sbomify.com/CVE-2026-102267/): PyJWT: PyJWKClient follows redirects when fetching JWKS (high 7.4)
- [CVE-2026-102271](https://insights.sbomify.com/CVE-2026-102271/): PyJWT: Public keys in DER form are accepted as HMAC secrets, bypassing the CVE-2022-29217 guard (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102269 and fix it if it is affected.

What it is: CVE-2026-102269 is a medium-severity vulnerability in jpadilla pyjwt, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102269 exists.

Affected packages and fixed versions:
- pyjwt (PyPI): affected all versions; fixed in 2.14.0
- pyjwt (PyPI): affected all versions; fixed in 2.14.0
- PyJWT (PyPI): affected all versions; fixed in 2.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102269/ (Markdown: https://insights.sbomify.com/CVE-2026-102269/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102269
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102269
- OSV: https://osv.dev/vulnerability/CVE-2026-102269

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102269/
Summaries are generated and may contain mistakes; the official description above is the record.
