# CVE-2026-102272: PyJWT BOM Bypass

> Attackers can forge authenticated tokens by exploiting a BOM parsing flaw in PyJWT's key detection, bypassing signature verification.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** AZL-105224, CLEANSTART-2026-GJ26931, CLEANSTART-2026-YQ31003, DEBIAN-CVE-2026-102272, ECHO-20d5-2851-e01f, GHSA-r6x4-923q-g947, MINI-2chf-753x-64x4, MINI-2p9h-qh8j-frhv, MINI-42r5-78p5-5v39, MINI-49p6-36pm-ppqp, MINI-4gcj-26rw-48w3, MINI-5252-8w5c-gwxm, MINI-7jjp-qr53-gf44, MINI-84x3-4rpv-qc6x, MINI-9mjh-hx2j-wmr9, MINI-hc57-pr3j-g8x5, MINI-p6vf-cxvr-962g, MINI-q9xp-pqqc-8gf7, MINI-vc2x-gxf7-jqp9, MINI-xc72-c54p-27qc, PYSEC-2026-4150, ROOT-APP-PYPI-CVE-2026-102272, UBUNTU-CVE-2026-102272

## What is CVE-2026-102272?

CVE-2026-102272 is a high-severity vulnerability in jpadilla pyjwt, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PyJWT is a Python implementation of JSON Web Token standards. From 2.13.0 until 2.14.0, HMACAlgorithm.prepare_key in jwt/algorithms.py is affected because raw-JWK detector does not normalize accepted Unicode byte-order marks before checking for JSON. This occurs when a public JWK is prefixed with a UTF-8 BOM and used in a mixed-algorithm verification path. As a result, public JWK bypasses asymmetric-key detection and becomes the HMAC secret. Consequently, an attacker who knows the public key can forge authenticated tokens. This issue is fixed in version 2.14.0.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-102272?

3 open source packages ship an affected version, including pyjwt and PyJWT. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyjwt` | PyPI | From 2.13.0 | 2.14.0 |
| `pyjwt` | PyPI | From 2.13.0 | 2.14.0 |
| `PyJWT` | PyPI | From 2.13.0 | 2.14.0 |

Products: Pyjwt Project Pyjwt.

## How do I fix CVE-2026-102272?

Upgrade pyjwt to 2.14.0 or later.

## Is CVE-2026-102272 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102272 exists.

## Other vulnerabilities in jpadilla pyjwt

- [CVE-2026-102268](https://insights.sbomify.com/CVE-2026-102268/): PyJWT: Asymmetric-PEM detection bypass: whitespace/line-ending-mutated public keys skip the HS/asymmetric confusion guard (critical 9.1)
- [CVE-2026-32597](https://insights.sbomify.com/CVE-2026-32597/): PyJWT accepts unknown `crit` header extensions (RFC 7515 §4.1.11 MUST violation) (high 7.5)
- [CVE-2026-102266](https://insights.sbomify.com/CVE-2026-102266/): PyJWK accepts empty HMAC keys, bypassing PyJWT's empty-key validation (high 7.4)
- [CVE-2026-102267](https://insights.sbomify.com/CVE-2026-102267/): PyJWT: PyJWKClient follows redirects when fetching JWKS (high 7.4)
- [CVE-2026-102271](https://insights.sbomify.com/CVE-2026-102271/): PyJWT: Public keys in DER form are accepted as HMAC secrets, bypassing the CVE-2022-29217 guard (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102272 and fix it if it is affected.

What it is: CVE-2026-102272 is a high-severity vulnerability in jpadilla pyjwt, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102272 exists.

Affected packages and fixed versions:
- pyjwt (PyPI): affected from 2.13.0; fixed in 2.14.0
- pyjwt (PyPI): affected from 2.13.0; fixed in 2.14.0
- PyJWT (PyPI): affected from 2.13.0; fixed in 2.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102272/ (Markdown: https://insights.sbomify.com/CVE-2026-102272/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102272
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102272
- OSV: https://osv.dev/vulnerability/CVE-2026-102272

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102272/
Summaries are generated and may contain mistakes; the official description above is the record.
