# CVE-2026-102274: PyJWT: Malformed RSA JWK aborts parsing of an entire JWK Set

> A malformed RSA key in a JWK Set causes PyJWT to abort parsing, leading to authentication failures or denial of service for applications using the library.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** AZL-105236, CLEANSTART-2026-LD97842, CLEANSTART-2026-YX87387, CLSA-2026-1790745888, DEBIAN-CVE-2026-102274, ECHO-aad4-edd4-a5d2, GHSA-w6j9-cwv2-h6wq, MINI-2g8f-hqrv-722w, MINI-2gf7-mfrj-c46v, MINI-3cr4-mpv4-r6g9, MINI-473m-gwhh-7pmr, MINI-4jcp-x72p-7q7g, MINI-656c-5gpj-4qp9, MINI-6qff-4fp2-wvcx, MINI-6whw-qrq2-98cr, MINI-7c4x-5xxq-4fwp, MINI-98m8-4pp5-r234, MINI-9q73-c76f-pqvh, MINI-cxhx-f4mm-99xc, MINI-f9xh-xmfw-9635, MINI-j53j-7gr9-j5x3, MINI-j7v4-83q2-vcm2, MINI-jgr3-7cq8-8vjf, MINI-jm98-p6r9-xmr9, MINI-mcj4-f462-rr9h, MINI-mv4r-c66g-4v3r, MINI-p8v5-g93m-xqc4, MINI-v7g2-2c4g-q7wg, MINI-v8qx-64h9-wfxg, MINI-w88h-2v2q-v4r8, MINI-x3fr-rh85-wq57, MINI-x5w4-778w-cfqh, PYSEC-2026-4152, UBUNTU-CVE-2026-102274

## What is CVE-2026-102274?

CVE-2026-102274 is a medium-severity denial of service vulnerability in jpadilla pyjwt, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PyJWT is a Python implementation of JSON Web Token standards. From 2.9.0 until 2.14.0, PyJWKSet does not catch the plain ValueError raised for malformed RSA JWK components by RSAAlgorithm.from_jwk in  jwt/api_jwk.py. This occurs when a JWK Set contains a malformed RSA key alongside otherwise usable keys. As a result, one malformed member aborts construction of the entire PyJWKSet. Consequently, applications can experience authentication failures or request-level denial of service. This issue is fixed in version 2.14.0.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2026-102274?

3 open source packages ship an affected version, including pyjwt and PyJWT. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyjwt` | PyPI | From 2.9.0 | 2.14.0 |
| `pyjwt` | PyPI | From 2.9.0 | 2.14.0 |
| `PyJWT` | PyPI | From 2.9.0 | 2.14.0 |

Products: Pyjwt Project Pyjwt.

## How do I fix CVE-2026-102274?

Upgrade pyjwt to 2.14.0 or later.

## Is CVE-2026-102274 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102274 exists.

## Other vulnerabilities in jpadilla pyjwt

- [CVE-2026-102268](https://insights.sbomify.com/CVE-2026-102268/): PyJWT: Asymmetric-PEM detection bypass: whitespace/line-ending-mutated public keys skip the HS/asymmetric confusion guard (critical 9.1)
- [CVE-2026-32597](https://insights.sbomify.com/CVE-2026-32597/): PyJWT accepts unknown `crit` header extensions (RFC 7515 §4.1.11 MUST violation) (high 7.5)
- [CVE-2026-102266](https://insights.sbomify.com/CVE-2026-102266/): PyJWK accepts empty HMAC keys, bypassing PyJWT's empty-key validation (high 7.4)
- [CVE-2026-102267](https://insights.sbomify.com/CVE-2026-102267/): PyJWT: PyJWKClient follows redirects when fetching JWKS (high 7.4)
- [CVE-2026-102271](https://insights.sbomify.com/CVE-2026-102271/): PyJWT: Public keys in DER form are accepted as HMAC secrets, bypassing the CVE-2022-29217 guard (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102274 and fix it if it is affected.

What it is: CVE-2026-102274 is a medium-severity denial of service vulnerability in jpadilla pyjwt, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102274 exists.

Affected packages and fixed versions:
- pyjwt (PyPI): affected from 2.9.0; fixed in 2.14.0
- pyjwt (PyPI): affected from 2.9.0; fixed in 2.14.0
- PyJWT (PyPI): affected from 2.9.0; fixed in 2.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102274/ (Markdown: https://insights.sbomify.com/CVE-2026-102274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102274
- OSV: https://osv.dev/vulnerability/CVE-2026-102274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102274/
Summaries are generated and may contain mistakes; the official description above is the record.
