CVE-2026-102276 brace-expansion: DoS via uncontrolled recursion in parseCommaParts causing stack exhaustion
Crafted brace patterns cause stack exhaustion in the brace-expansion library, leading to a Node.js process crash and denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-102276?
CVE-2026-102276 is a high-severity denial of service vulnerability in juliangruber brace-expansion, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.19, 2.1.5, 3.0.7, and 5.0.10, crafted brace patterns can exhaust the native stack in parseCommaParts because parseCommaParts recursively processes the remainder once per brace group and uses push.apply to pass every element of a very large comma-part array as a function argument. Patterns containing many comma-separated brace groups trigger the recursive path, while the large array triggers the argument-array path without deep recursion. These paths cause recursive and argument-array native stack exhaustion before max or maxLength can limit output, potentially terminating the Node.js process in a process-terminating denial of service. This issue is fixed in versions 1.1.19, 2.1.5, 3.0.7, and 5.0.10.
Which versions are affected by CVE-2026-102276?
8 open source packages ship an affected version, including brace-expansion.
| Package | Affected | Fixed in |
|---|---|---|
brace-expansion npm | All versions | 1.1.19 |
brace-expansion npm | All versions | 1.1.19 |
brace-expansion npm | From 2.0.0 | 2.1.5 |
brace-expansion npm | From 2.0.0 | 2.1.5 |
brace-expansion npm | From 3.0.0 | 3.0.7 |
brace-expansion npm | From 3.0.0 | 3.0.7 |
2 more packages
brace-expansion npm | From 4.0.0 | 5.0.10 |
brace-expansion npm | From 4.0.0 | 5.0.10 |
Linux distribution packages (1)
pi-coding-agent openSUSE:Tumbleweed | All versions | 1.0.2-1.1 |
How do I fix CVE-2026-102276?
Upgrade brace-expansion to a fixed version for your release line: 1.1.19, 2.1.5, 3.0.7 or 5.0.10.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-102276 being exploited?
There is no known exploitation of CVE-2026-102276 in the wild and no public exploit code.
Sources
Also known as AZL-105075, AZL-105096, AZL-105248, CLEANSTART-2026-DU29459, CLEANSTART-2026-DY98563, CLEANSTART-2026-KY36668 and 56 more.