# CVE-2026-102276: brace-expansion: DoS via uncontrolled recursion in parseCommaParts causing stack exhaustion

> Crafted brace patterns cause stack exhaustion in the brace-expansion library, leading to a Node.js process crash and denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** AZL-105075, AZL-105096, AZL-105248, CLEANSTART-2026-DU29459, CLEANSTART-2026-DY98563, CLEANSTART-2026-KY36668, CLEANSTART-2026-MC48922, CLEANSTART-2026-NW59301, CLEANSTART-2026-QQ47371, CLSA-2026-1790807349, CLSA-2026-1790807354, CLSA-2026-1790807467, CLSA-2026-1790856945, CLSA-2026-1790863041, CLSA-2026-1790864778, CLSA-2026-1791215851, CLSA-2026-1791215922, CLSA-2026-1791226379, CLSA-2026-1791226863, CLSA-2026-1791278923, DEBIAN-CVE-2026-102276, ECHO-5000-011f-5261, GHSA-6j4f-fj2g-mc7p, MINI-27xx-qgrm-vqc4, MINI-2p92-9qfw-p6wc, MINI-3f77-m92v-2xmr, MINI-3m36-hq59-q5qc, MINI-49fv-g965-4rc4, MINI-4m38-4g64-wc55, MINI-52m4-2x6p-f5fm, MINI-5m6j-7qj5-7rgp, MINI-5mx9-x3vm-qwqx, MINI-5q3m-vf89-3c6p, MINI-6f3m-c8rr-38wq, MINI-7f9w-jqwq-vmqc, MINI-8cr9-j7p4-jfvc, MINI-8j97-9cj4-chjx, MINI-9g7m-jhm9-w2p4, MINI-9q2r-7xpq-fqf7, MINI-c4vq-39fv-9fhh, MINI-cjwf-vj2q-245v, MINI-cv6g-8pgf-j8qf, MINI-cv8v-24vr-7fw9, MINI-fjqr-7wxw-9mh7, MINI-gf4j-56vc-xfg9, MINI-h87f-q8jh-7j85, MINI-j888-v9wp-5cqg, MINI-mgg3-hjm4-fwpf, MINI-p3r6-2h7q-xqr5, MINI-p4w5-jvrm-gpcx, MINI-pcwx-jjmp-xqgw, MINI-pxww-wrfx-jpr7, MINI-q3x2-pgvv-qgw6, MINI-rp5m-m6v6-gv4j, MINI-rph4-33gm-3mr9, MINI-rvc4-7q6f-qrh2, MINI-vcfc-w6hc-g2c7, MINI-w73w-3j88-mv8m, MINI-wpxr-v5hp-mvp3, ROOT-APP-NPM-CVE-2026-102276, UBUNTU-CVE-2026-102276, openSUSE-SU-2026:12062-1

## What is CVE-2026-102276?

CVE-2026-102276 is a high-severity denial of service vulnerability in juliangruber brace-expansion, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.19, 2.1.5, 3.0.7, and 5.0.10, crafted brace patterns can exhaust the native stack in parseCommaParts because parseCommaParts recursively processes the remainder once per brace group and uses push.apply to pass every element of a very large comma-part array as a function argument. Patterns containing many comma-separated brace groups trigger the recursive path, while the large array triggers the argument-array path without deep recursion. These paths cause recursive and argument-array native stack exhaustion before max or maxLength can limit output, potentially terminating the Node.js process in a process-terminating denial of service. This issue is fixed in versions 1.1.19, 2.1.5, 3.0.7, and 5.0.10.

Weakness: CWE-674 (Uncontrolled Recursion), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-102276?

8 open source packages ship an affected version, including brace-expansion.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `brace-expansion` | npm | All versions | 1.1.19 |
| `brace-expansion` | npm | All versions | 1.1.19 |
| `brace-expansion` | npm | From 2.0.0 | 2.1.5 |
| `brace-expansion` | npm | From 2.0.0 | 2.1.5 |
| `brace-expansion` | npm | From 3.0.0 | 3.0.7 |
| `brace-expansion` | npm | From 3.0.0 | 3.0.7 |
| `brace-expansion` | npm | From 4.0.0 | 5.0.10 |
| `brace-expansion` | npm | From 4.0.0 | 5.0.10 |
| `pi-coding-agent` | openSUSE:Tumbleweed | All versions | 1.0.2-1.1 |

## How do I fix CVE-2026-102276?

Upgrade brace-expansion to a fixed version for your release line: 1.1.19, 2.1.5, 3.0.7 or 5.0.10.

## Is CVE-2026-102276 being exploited?

There is no known exploitation of CVE-2026-102276 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102276 and fix it if it is affected.

What it is: CVE-2026-102276 is a high-severity denial of service vulnerability in juliangruber brace-expansion, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102276 in the wild and no public exploit code.

Affected packages and fixed versions:
- brace-expansion (npm): affected all versions; fixed in 1.1.19
- brace-expansion (npm): affected all versions; fixed in 1.1.19
- brace-expansion (npm): affected from 2.0.0; fixed in 2.1.5
- brace-expansion (npm): affected from 2.0.0; fixed in 2.1.5
- brace-expansion (npm): affected from 3.0.0; fixed in 3.0.7
- brace-expansion (npm): affected from 3.0.0; fixed in 3.0.7
- brace-expansion (npm): affected from 4.0.0; fixed in 5.0.10
- brace-expansion (npm): affected from 4.0.0; fixed in 5.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102276/ (Markdown: https://insights.sbomify.com/CVE-2026-102276/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102276
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102276
- OSV: https://osv.dev/vulnerability/CVE-2026-102276

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102276/
Summaries are generated and may contain mistakes; the official description above is the record.
