# CVE-2026-102277: brace-expansion: Quadratic-time expansion of the `{a},b}` rewrite causes CPU denial of service

> Attackers can cause CPU denial of service in Node.js applications by supplying crafted brace expansion patterns that trigger quadratic time complexity.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** AZL-105072, AZL-105089, AZL-105251, CLEANSTART-2026-DK31702, CLEANSTART-2026-GM91352, CLEANSTART-2026-GY49869, CLEANSTART-2026-ME50166, CLEANSTART-2026-ZD57253, CLSA-2026-1790854736, CLSA-2026-1790856851, CLSA-2026-1790862940, CLSA-2026-1790864782, CLSA-2026-1790869488, CLSA-2026-1790870256, CLSA-2026-1791226583, CLSA-2026-1791226683, CLSA-2026-1791278751, CLSA-2026-1791279204, CLSA-2026-1791282750, CLSA-2026-1791285043, CLSA-2026-1791304072, CLSA-2026-1791666934, DEBIAN-CVE-2026-102277, ECHO-57b4-e1a8-8839, GHSA-q2hr-2g5m-vwhr, MINI-32wr-7hc2-gg6q, MINI-3wh8-22mx-7pf6, MINI-3wmq-cf8r-7j2m, MINI-47g6-vhfh-r29x, MINI-49vw-24mg-vfhv, MINI-4vp4-55p7-58xp, MINI-5mx9-w6j8-vwvx, MINI-6899-f56c-hg6r, MINI-6g32-c92j-c32x, MINI-6x4f-ggp4-m6xg, MINI-7843-8595-qrpf, MINI-7fm8-325h-p25m, MINI-85j2-f559-vjrx, MINI-8w8v-27c7-f9cc, MINI-c9m4-grq5-8w6f, MINI-cvwv-56q5-v624, MINI-fhxr-9wmc-5349, MINI-fxgq-6x6h-f82r, MINI-gc29-65w9-92q5, MINI-h4jr-rh65-xjw9, MINI-hjj7-2f7p-c75q, MINI-hv7g-32rf-gj6p, MINI-j7v4-4m98-w682, MINI-p5hw-6457-p2c7, MINI-q3mp-p623-v6wq, MINI-q3w8-pw3q-vvxw, MINI-qh3m-6g7h-jhf2, MINI-qhv2-7vqh-v892, MINI-rjj5-38hh-4mgr, MINI-v3p7-ppfg-g494, MINI-vc58-j29h-m5cr, MINI-wr9v-v3rc-mrxw, MINI-x74f-9mg4-6cfp, MINI-xcw3-pjc3-pc9x, MINI-xgrp-797p-762m, MINI-xv5p-wf5q-846g, UBUNTU-CVE-2026-102277

## What is CVE-2026-102277?

CVE-2026-102277 is a medium-severity denial of service vulnerability in juliangruber brace-expansion, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.21, 2.1.7, 3.0.9, and 5.0.12, the expand function handles untrusted {a},b}-shaped patterns with many trailing closing braces by restarting its scan once for each trailing closing brace. The successive full-input rescans with linear working-string growth cause quadratic CPU time and memory pressure that can block the Node.js event loop. The process eventually recovers, making the impact a recoverable CPU denial of service. This issue is fixed in versions 1.1.21, 2.1.7, 3.0.9, and 5.0.12.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-102277?

8 open source packages ship an affected version, including brace-expansion.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `brace-expansion` | npm | All versions | 1.1.21 |
| `brace-expansion` | npm | All versions | 1.1.21 |
| `brace-expansion` | npm | From 2.0.0 | 2.1.7 |
| `brace-expansion` | npm | From 2.0.0 | 2.1.7 |
| `brace-expansion` | npm | From 3.0.0 | 3.0.9 |
| `brace-expansion` | npm | From 3.0.0 | 3.0.9 |
| `brace-expansion` | npm | From 4.0.0 | 5.0.12 |
| `brace-expansion` | npm | From 4.0.0 | 5.0.12 |

## How do I fix CVE-2026-102277?

Upgrade brace-expansion to a fixed version for your release line: 1.1.21, 2.1.7, 3.0.9 or 5.0.12.

## Is CVE-2026-102277 being exploited?

There is no known exploitation of CVE-2026-102277 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102277 and fix it if it is affected.

What it is: CVE-2026-102277 is a medium-severity denial of service vulnerability in juliangruber brace-expansion, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102277 in the wild and no public exploit code.

Affected packages and fixed versions:
- brace-expansion (npm): affected all versions; fixed in 1.1.21
- brace-expansion (npm): affected all versions; fixed in 1.1.21
- brace-expansion (npm): affected from 2.0.0; fixed in 2.1.7
- brace-expansion (npm): affected from 2.0.0; fixed in 2.1.7
- brace-expansion (npm): affected from 3.0.0; fixed in 3.0.9
- brace-expansion (npm): affected from 3.0.0; fixed in 3.0.9
- brace-expansion (npm): affected from 4.0.0; fixed in 5.0.12
- brace-expansion (npm): affected from 4.0.0; fixed in 5.0.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102277/ (Markdown: https://insights.sbomify.com/CVE-2026-102277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102277
- OSV: https://osv.dev/vulnerability/CVE-2026-102277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102277/
Summaries are generated and may contain mistakes; the official description above is the record.
