CVE-2026-102279 Laravel: XSS in Debug Page Information
Attackers can execute arbitrary JavaScript via DOM-based XSS in Laravel debug pages when APP_DEBUG is enabled, requiring user interaction.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-102279?
CVE-2026-102279 is a low-severity cross-site scripting vulnerability in laravel framework, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Laravel is a web application framework. Prior to 12.69.0 and 13.30.0, Laravel exception debug pages with APP_DEBUG=true pass attacker-controlled input to a Tippy.js tooltip configured with allowHTML true, enabling DOM-based cross-site scripting when a user hovers over the tooltip. This issue is fixed in versions 12.69.0 and 13.30.0.
Weakness: CWE-80
Which versions are affected by CVE-2026-102279?
4 open source packages ship an affected version, including laravel/framework.
| Package | Affected | Fixed in |
|---|---|---|
laravel/framework Packagist | All versions | 12.69.0 |
laravel/framework Packagist | All versions | 12.69.0 |
laravel/framework Packagist | From 13.0.0 | 13.30.0 |
laravel/framework Packagist | From 13.0.0 | 13.30.0 |
How do I fix CVE-2026-102279?
Upgrade laravel/framework to a fixed version for your release line: 12.69.0 or 13.30.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-102279 being exploited?
There is no known exploitation of CVE-2026-102279 in the wild and no public exploit code.
Sources
Also known as CLSA-2026-1790868507, DEBIAN-CVE-2026-102279, GHSA-jh5r-qr3c-85q8.