# CVE-2026-102279: Laravel: XSS in Debug Page Information

> Attackers can execute arbitrary JavaScript via DOM-based XSS in Laravel debug pages when APP_DEBUG is enabled, requiring user interaction.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** CLSA-2026-1790868507, DEBIAN-CVE-2026-102279, GHSA-jh5r-qr3c-85q8

## What is CVE-2026-102279?

CVE-2026-102279 is a low-severity cross-site scripting vulnerability in laravel framework, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Laravel is a web application framework. Prior to 12.69.0 and 13.30.0, Laravel exception debug pages with APP_DEBUG=true pass attacker-controlled input to a Tippy.js tooltip configured with allowHTML true, enabling DOM-based cross-site scripting when a user hovers over the tooltip. This issue is fixed in versions 12.69.0 and 13.30.0.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-102279?

4 open source packages ship an affected version, including laravel/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `laravel/framework` | Packagist | All versions | 12.69.0 |
| `laravel/framework` | Packagist | All versions | 12.69.0 |
| `laravel/framework` | Packagist | From 13.0.0 | 13.30.0 |
| `laravel/framework` | Packagist | From 13.0.0 | 13.30.0 |

## How do I fix CVE-2026-102279?

Upgrade laravel/framework to a fixed version for your release line: 12.69.0 or 13.30.0.

## Is CVE-2026-102279 being exploited?

There is no known exploitation of CVE-2026-102279 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102279 and fix it if it is affected.

What it is: CVE-2026-102279 is a low-severity cross-site scripting vulnerability in laravel framework, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-102279 in the wild and no public exploit code.

Affected packages and fixed versions:
- laravel/framework (Packagist): affected all versions; fixed in 12.69.0
- laravel/framework (Packagist): affected all versions; fixed in 12.69.0
- laravel/framework (Packagist): affected from 13.0.0; fixed in 13.30.0
- laravel/framework (Packagist): affected from 13.0.0; fixed in 13.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102279/ (Markdown: https://insights.sbomify.com/CVE-2026-102279/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102279
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102279
- OSV: https://osv.dev/vulnerability/CVE-2026-102279

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102279/
Summaries are generated and may contain mistakes; the official description above is the record.
