CVE-2026-102281 Nest: Remote process termination via a deeply nested microservice message pattern
Attackers can crash NestJS microservices using TCP or RabbitMQ transports by sending deeply nested message patterns, causing unhandled exceptions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-102281?
CVE-2026-102281 is a high-severity denial of service vulnerability in nestjs nest, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Nest is a framework for building scalable Node.js server-side applications. Prior to 11.2.4 and 12.0.2, a single message with a deeply nested object in its pattern can terminate a NestJS microservice using the TCP or RabbitMQ transport. ServerTCP#handleMessage and ServerRMQ#handleMessage pass a client-controlled non-string pattern to JSON.stringify to derive the handler lookup key; sufficiently deep nesting throws RangeError: Maximum call stack size exceeded, and the unhandled promise rejection terminates Node.js under its default behavior. An attacker who can reach the TCP port or publish to the consumed RabbitMQ queue or exchange can crash the service on demand; other transports are not affected because their patterns arrive as strings. This issue is fixed in versions 11.2.4 and 12.0.2.
Which versions are affected by CVE-2026-102281?
4 open source packages ship an affected version, including @nestjs/microservices.
| Package | Affected | Fixed in |
|---|---|---|
@nestjs/microservices npm | All versions | 11.2.4 |
@nestjs/microservices npm | All versions | 11.2.4 |
@nestjs/microservices npm | From 12.0.0 | 12.0.2 |
@nestjs/microservices npm | From 12.0.0 | 12.0.2 |
How do I fix CVE-2026-102281?
Upgrade @nestjs/microservices to a fixed version for your release line: 11.2.4 or 12.0.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-102281 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102281 exists.
Sources
Also known as CLSA-2026-1792265594, CLSA-2026-1792325070, CLSA-2026-1792325945, ECHO-b32d-d5e9-7a88, GHSA-m8vh-jmq9-5rjg.