# CVE-2026-102281: Nest: Remote process termination via a deeply nested microservice message pattern

> Attackers can crash NestJS microservices using TCP or RabbitMQ transports by sending deeply nested message patterns, causing unhandled exceptions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** CLSA-2026-1792265594, CLSA-2026-1792325070, CLSA-2026-1792325945, ECHO-b32d-d5e9-7a88, GHSA-m8vh-jmq9-5rjg

## What is CVE-2026-102281?

CVE-2026-102281 is a high-severity denial of service vulnerability in nestjs nest, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nest is a framework for building scalable Node.js server-side applications. Prior to 11.2.4 and 12.0.2, a single message with a deeply nested object in its pattern can terminate a NestJS microservice using the TCP or RabbitMQ transport. ServerTCP#handleMessage and ServerRMQ#handleMessage pass a client-controlled non-string pattern to JSON.stringify to derive the handler lookup key; sufficiently deep nesting throws RangeError: Maximum call stack size exceeded, and the unhandled promise rejection terminates Node.js under its default behavior. An attacker who can reach the TCP port or publish to the consumed RabbitMQ queue or exchange can crash the service on demand; other transports are not affected because their patterns arrive as strings. This issue is fixed in versions 11.2.4 and 12.0.2.

Weakness: CWE-674 (Uncontrolled Recursion), CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-102281?

4 open source packages ship an affected version, including @nestjs/microservices.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nestjs/microservices` | npm | All versions | 11.2.4 |
| `@nestjs/microservices` | npm | All versions | 11.2.4 |
| `@nestjs/microservices` | npm | From 12.0.0 | 12.0.2 |
| `@nestjs/microservices` | npm | From 12.0.0 | 12.0.2 |

## How do I fix CVE-2026-102281?

Upgrade @nestjs/microservices to a fixed version for your release line: 11.2.4 or 12.0.2.

## Is CVE-2026-102281 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102281 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102281 and fix it if it is affected.

What it is: CVE-2026-102281 is a high-severity denial of service vulnerability in nestjs nest, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102281 exists.

Affected packages and fixed versions:
- @nestjs/microservices (npm): affected all versions; fixed in 11.2.4
- @nestjs/microservices (npm): affected all versions; fixed in 11.2.4
- @nestjs/microservices (npm): affected from 12.0.0; fixed in 12.0.2
- @nestjs/microservices (npm): affected from 12.0.0; fixed in 12.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102281/ (Markdown: https://insights.sbomify.com/CVE-2026-102281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102281
- OSV: https://osv.dev/vulnerability/CVE-2026-102281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102281/
Summaries are generated and may contain mistakes; the official description above is the record.
