{"answers":{"affected":"2 open source packages ship an affected version, including pbkdf2.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102414 exists.","fix":"Upgrade pbkdf2 to 3.1.7 or later.","what":"CVE-2026-102414 is a medium-severity denial of service vulnerability in browserify pbkdf2, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-102414 and fix it if it is affected.\n\nWhat it is: CVE-2026-102414 is a medium-severity denial of service vulnerability in browserify pbkdf2, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102414 exists.\n\nAffected packages and fixed versions:\n- pbkdf2 (npm): affected all versions; fixed in 3.1.7\n- pbkdf2 (npm): affected all versions; fixed in 3.1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-102414/ (Markdown: https://insights.sbomify.com/CVE-2026-102414/index.md)","id":"CVE-2026-102414","markdown":"https://insights.sbomify.com/CVE-2026-102414/index.md","name":"CVE-2026-102414","record":{"aliases":["CLSA-2026-1793205450","DEBIAN-CVE-2026-102414","GHSA-477h-4r7f-fvrx","MINI-2hv7-3cj6-p8hp","MINI-5q58-6wp2-pgff","MINI-5vvx-m35x-c4pj","MINI-g757-7qcp-28qx","MINI-j366-vj4g-cgg4","UBUNTU-CVE-2026-102414"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js crypto library","requires_auth":"none","summary":"Attackers can cause denial of service by submitting long passwords to pbkdf2, forcing expensive re-hashing on every iteration in specific JavaScript environments.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"harborist","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"pbkdf2 through 3.1.6 re-hashes passwords longer than the digest's block size on every iteration in its JavaScript fallback (lib/sync.js). A password longer than the block size (64 bytes, or 128 bytes for sha384 and sha512) is passed to HMAC as the key on every iteration, and HMAC hashes such keys in full each time. Cost is therefore O(iterations × password length), and a long password can block the event loop. The fallback is used by pbkdf2Sync and pbkdf2 on Node.js before 0.12, on Bun (1.0.0 through 1.1.34, and 1.2.6 and later), and on Deno 2.9.0 and later, because their native pbkdf2Sync fails the library's feature check. It is also used when lib/sync.js is imported directly. Node.js 0.12 and later, and browser builds (which use lib/sync-browser.js), are not affected. Applications that enforce a reasonable maximum password length are not meaningfully affected.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"pbkdf2 rehashes long passwords on every iteration, enabling denial of service","id":"CVE-2026-102414","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"shell-quote `quote()` command injection via a line terminator in a token after a `{ comment }` token","id":"CVE-2026-102422"},"packages":[{"ecosystem":"npm","fixed":["3.1.7"],"introduced":["0"],"last_affected":[],"package":"pbkdf2","purl":null,"source":"GHSA-477h-4r7f-fvrx"},{"ecosystem":"npm","fixed":["3.1.7"],"introduced":["0"],"last_affected":[],"package":"pbkdf2","purl":"pkg:npm/pbkdf2","source":"GHSA-477h-4r7f-fvrx"}],"prev":{"headline":"Uncaught Exception in Elastic Endpoint Leading to Denial of Service","id":"CVE-2026-102413"},"products":["pbkdf2"],"published":"2026-09-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-30","vendors":["browserify"]},"summary":"Attackers can cause denial of service by submitting long passwords to pbkdf2, forcing expensive re-hashing on every iteration in specific JavaScript environments.","url":"https://insights.sbomify.com/CVE-2026-102414/"}