# CVE-2026-102414: pbkdf2 rehashes long passwords on every iteration, enabling denial of service

> Attackers can cause denial of service by submitting long passwords to pbkdf2, forcing expensive re-hashing on every iteration in specific JavaScript environments.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** CLSA-2026-1793205450, DEBIAN-CVE-2026-102414, GHSA-477h-4r7f-fvrx, MINI-2hv7-3cj6-p8hp, MINI-5q58-6wp2-pgff, MINI-5vvx-m35x-c4pj, MINI-g757-7qcp-28qx, MINI-j366-vj4g-cgg4, UBUNTU-CVE-2026-102414

## What is CVE-2026-102414?

CVE-2026-102414 is a medium-severity denial of service vulnerability in browserify pbkdf2, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pbkdf2 through 3.1.6 re-hashes passwords longer than the digest's block size on every iteration in its JavaScript fallback (lib/sync.js). A password longer than the block size (64 bytes, or 128 bytes for sha384 and sha512) is passed to HMAC as the key on every iteration, and HMAC hashes such keys in full each time. Cost is therefore O(iterations × password length), and a long password can block the event loop. The fallback is used by pbkdf2Sync and pbkdf2 on Node.js before 0.12, on Bun (1.0.0 through 1.1.34, and 1.2.6 and later), and on Deno 2.9.0 and later, because their native pbkdf2Sync fails the library's feature check. It is also used when lib/sync.js is imported directly. Node.js 0.12 and later, and browser builds (which use lib/sync-browser.js), are not affected. Applications that enforce a reasonable maximum password length are not meaningfully affected.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-102414?

2 open source packages ship an affected version, including pbkdf2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pbkdf2` | npm | All versions | 3.1.7 |
| `pbkdf2` | npm | All versions | 3.1.7 |

## How do I fix CVE-2026-102414?

Upgrade pbkdf2 to 3.1.7 or later.

## Is CVE-2026-102414 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102414 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102414 and fix it if it is affected.

What it is: CVE-2026-102414 is a medium-severity denial of service vulnerability in browserify pbkdf2, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102414 exists.

Affected packages and fixed versions:
- pbkdf2 (npm): affected all versions; fixed in 3.1.7
- pbkdf2 (npm): affected all versions; fixed in 3.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102414/ (Markdown: https://insights.sbomify.com/CVE-2026-102414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102414
- OSV: https://osv.dev/vulnerability/CVE-2026-102414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102414/
Summaries are generated and may contain mistakes; the official description above is the record.
