# CVE-2026-102497: Apache XMLSchema: Denial of service through cyclic schema definitions in the schema walker

> A malicious XML schema can cause infinite recursion in the Apache XMLSchema walker, leading to a stack overflow and denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-9wgm-rwmh-4mcv

## What is CVE-2026-102497?

CVE-2026-102497 is a high-severity denial of service vulnerability in Apache XMLSchema, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Apache XmlSchema walker (xmlschema-walker) doesn't detect cycles in type derivation, substitution groups, model groups or attribute groups. A malicious schema with such a cycle can make the walker recurse until the stack overflows, causing a denial of service.

Users are recommended to upgrade to version 2.3.3, which fixes this issue.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-102497?

It affects 1 product.


Products: Apache Xmlschema.

## How do I fix CVE-2026-102497?

No fix has been published for CVE-2026-102497 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-102497 being exploited?

There is no known exploitation of CVE-2026-102497 in the wild and no public exploit code.

## Other vulnerabilities in Apache XMLSchema

- [CVE-2026-102495](https://insights.sbomify.com/CVE-2026-102495/): Apache XMLSchema: Denial of service through unbounded recursion when resolving schema imports and includes (high 7.5)
- [CVE-2026-102496](https://insights.sbomify.com/CVE-2026-102496/): Apache XMLSchema: Denial of service through deeply nested schema structures (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102497 and fix it if it is affected.

What it is: CVE-2026-102497 is a high-severity denial of service vulnerability in Apache XMLSchema, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102497 in the wild and no public exploit code.

Affected product: Apache XMLSchema. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102497/ (Markdown: https://insights.sbomify.com/CVE-2026-102497/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102497
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102497
- OSV: https://osv.dev/vulnerability/CVE-2026-102497

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102497/
Summaries are generated and may contain mistakes; the official description above is the record.
