{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-102508 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-102508 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-102508 is a critical vulnerability in Apache PLC4X, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-102508 and fix it if it is affected.\n\nWhat it is: CVE-2026-102508 is a critical vulnerability in Apache PLC4X, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-102508 in the wild and no public exploit code.\n\nAffected product: Apache PLC4X. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-102508/ (Markdown: https://insights.sbomify.com/CVE-2026-102508/index.md)","id":"CVE-2026-102508","markdown":"https://insights.sbomify.com/CVE-2026-102508/index.md","name":"CVE-2026-102508","record":{"aliases":["GHSA-f4cq-mfh7-4385"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Industrial IoT library","requires_auth":"none","summary":"Attackers can bypass OPC UA security checks to impersonate servers, read or modify traffic, and steal credentials in Apache PLC4X.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":9.2,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-757","name":"Selection of Less-Secure Algorithm During Negotiation"},{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"},{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Improper Verification of Cryptographic Signature and Improper Certificate Validation in the OPC UA driver of Apache PLC4X (PLC4J) allows an attacker in a network position between client and server to impersonate the OPC UA server and to read, forge or modify secure-channel traffic, including user credential ssent by the client.\n\nThe defect manifests differently depending on the version:\n- In 0.9.0 through 0.11.0 a failed message-signature check is only logged and never enforced, and there is no mechanism to verify the server certificate: it is taken from the unauthenticated GetEndpoints discovery response and used to encrypt the user's password.\n- In 0.12.0 through 0.13.1 the signature check is inverted (valid signatures are rejected, invalid ones accepted), and server certificates are accepted without a trust anchor by default.\n- In all affected versions the default security policy is None. Starting with 0.12.0 the driver additionally continues silently at a weaker security policy than the one configured, and starting with 0.13.0 endpoint selection prefers the weakest matching endpoint.\n\nUsers checking only for one of these mechanisms may wrongly conclude they are unaffected.\n\nThis issue affects Apache PLC4X: from 0.9.0 before 1.0.0.\n\nUsers are recommended to upgrade to version 1.0.0, which fixes the issue. Version 1.0.0 verifies message signatures correctly, refuses to connect unless the server certificate can be verified against a configured trust store or pinned certificate, defaults to Basic256Sha256 with SignAndEncrypt, and fails the\nconnection if the negotiated security policy is weaker than the configured one.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Apache PLC4X: OPC UA secure channel: integrity bypass, unverifiable server certificate, and silent downgrade","id":"CVE-2026-102508","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Apache PLC4X, Apache PLC4X: Pre-authentication resource exhaustion in the OPC UA driver and the Java SPI parser","id":"CVE-2026-102509"},"packages":[],"prev":{"headline":"Sliver 1.7.7 Denial of Service via PE Parser Slice Bounds in Operator RPC","id":"CVE-2026-102507"},"products":["Apache PLC4X"],"published":"2026-09-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-30","vendors":["Apache Software Foundation"]},"summary":"Attackers can bypass OPC UA security checks to impersonate servers, read or modify traffic, and steal credentials in Apache PLC4X.","url":"https://insights.sbomify.com/CVE-2026-102508/"}