# CVE-2026-102577: Moodle: ssrf risk in url downloader via ipv4-mapped ipv6 address bypass

> Authenticated attackers can bypass host restrictions in Moodle's URL downloader using IPv4-mapped IPv6 addresses to perform Server-Side Request Forgery.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** BIT-moodle-2026-102577, GHSA-29qm-g73m-2r7h, UBUNTU-CVE-2026-102577

## What is CVE-2026-102577?

CVE-2026-102577 is a medium-severity server-side request forgery vulnerability in Moodle Moodle, published on 30 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Moodle. Incorrect handling of IPv4-mapped IPv6 addresses within the URL downloader's host-blocking logic allows an authenticated remote user to bypass blocked-host restrictions. By supplying a crafted URL, an attacker can induce the server to make requests to restricted destinations, leading to Server-Side Request Forgery (SSRF).

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-102577?

1 open source package ship an affected version, including moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle` | Bitnami | All versions | 4.5.13, 5.0.9, 5.1.6, 5.2.2 |

Products: Moodle Moodle.

## How do I fix CVE-2026-102577?

Upgrade moodle to a fixed version for your release line: 4.5.13, 5.0.9, 5.1.6 or 5.2.2.

## Is CVE-2026-102577 being exploited?

There is no known exploitation of CVE-2026-102577 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102577 and fix it if it is affected.

What it is: CVE-2026-102577 is a medium-severity server-side request forgery vulnerability in Moodle Moodle, published on 30 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102577 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle (Bitnami): affected all versions; fixed in 4.5.13, 5.0.9, 5.1.6, 5.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102577/ (Markdown: https://insights.sbomify.com/CVE-2026-102577/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102577
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102577
- OSV: https://osv.dev/vulnerability/CVE-2026-102577

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102577/
Summaries are generated and may contain mistakes; the official description above is the record.
