CVE-2026-102578 Moodle: sql injection in question bank web service
An authenticated attacker can exploit SQL injection in the question bank web service to view, alter, or delete sensitive database data.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-102578?
CVE-2026-102578 is a medium-severity SQL injection vulnerability in Moodle Moodle, published on 30 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A flaw was found in Moodle. An authenticated attacker with access to the question bank web service can submit unsanitized input directly into database queries, resulting in a SQL (Structured Query Language) injection vulnerability. This issue could allow an attacker to view, alter, or delete sensitive data stored in the underlying database.
Weakness: CWE-89
Which versions are affected by CVE-2026-102578?
1 open source package ship an affected version, including moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle Bitnami | All versions | 4.5.13, 5.0.9, 5.1.6, 5.2.2 |
Products include Moodle Moodle.
How do I fix CVE-2026-102578?
Upgrade moodle to a fixed version for your release line: 4.5.13, 5.0.9, 5.1.6 or 5.2.2.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-102578 being exploited?
There is no known exploitation of CVE-2026-102578 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2026-102578, GHSA-hvr9-w78p-rcfj, UBUNTU-CVE-2026-102578.