CVE-2026-102580 Moodle: arbitrary class instantiation via report builder audience classname
Authenticated attackers can instantiate arbitrary classes in Moodle Report Builder, potentially leading to code execution or privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-102580?
CVE-2026-102580 is a low-severity code injection vulnerability in Moodle Moodle, published on 30 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A flaw was found in Moodle. An authenticated attacker can supply an improperly validated audience class name to the Report Builder component, allowing arbitrary class instantiation. This vulnerability enables the unauthorized creation of internal program objects, which may result in unexpected application behavior.
Weakness: CWE-470
Which versions are affected by CVE-2026-102580?
1 open source package ship an affected version, including moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle Bitnami | All versions | 4.5.13, 5.0.9, 5.1.6, 5.2.2 |
Products include Moodle Moodle.
How do I fix CVE-2026-102580?
Upgrade moodle to a fixed version for your release line: 4.5.13, 5.0.9, 5.1.6 or 5.2.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-102580 being exploited?
There is no known exploitation of CVE-2026-102580 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2026-102580, GHSA-xw58-hp5c-6wc2, UBUNTU-CVE-2026-102580.