CVE-2026-102581 Moodle: xss in forum post templates due to insufficient escaping
Stored XSS in Moodle forum posts allows attackers to execute arbitrary scripts in victims' browsers, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-102581?
CVE-2026-102581 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 30 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A flaw was found in Moodle. Insufficient output escaping in templates used to display forum posts enables a stored cross-site scripting (XSS) vulnerability. An attacker can inject malicious content into a forum post, which then executes arbitrary script code in the browser of another user viewing the affected post.
Weakness: CWE-79
Which versions are affected by CVE-2026-102581?
1 open source package ship an affected version, including moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle Bitnami | All versions | 4.5.13, 5.0.9, 5.1.6, 5.2.2 |
Products include Moodle Moodle.
How do I fix CVE-2026-102581?
Upgrade moodle to a fixed version for your release line: 4.5.13, 5.0.9, 5.1.6 or 5.2.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-102581 being exploited?
There is no known exploitation of CVE-2026-102581 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2026-102581, GHSA-g6pg-29qv-3h3r, UBUNTU-CVE-2026-102581.