CVE-2026-102582 Moodle: manual enrolment page accessible when plugin disabled
Authorized users can bypass disabled manual enrolment plugin settings to manage enrolments, requiring administrators to patch Moodle.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-102582?
CVE-2026-102582 is a low-severity missing authorization vulnerability in Moodle Moodle, published on 30 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A flaw was found in Moodle. The manual enrolment management page did not properly check whether the manual enrolment plugin was disabled, allowing users with enrolment permissions to access the page directly by navigating to its URL. Consequently, an authorized user could manage manual enrolments even after an administrator disabled the feature in the user interface.
Weakness: CWE-425
Which versions are affected by CVE-2026-102582?
1 open source package ship an affected version, including moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle Bitnami | All versions | 4.5.13, 5.0.9, 5.1.6, 5.2.2 |
Products include Moodle Moodle.
How do I fix CVE-2026-102582?
Upgrade moodle to a fixed version for your release line: 4.5.13, 5.0.9, 5.1.6 or 5.2.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-102582 being exploited?
There is no known exploitation of CVE-2026-102582 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2026-102582, GHSA-5rpx-cfm4-5485, UBUNTU-CVE-2026-102582.