CVE-2026-102584 Moodle: missing capability check allows unauthorised grade penalty recalculation
Low-privileged users can modify grade penalty records due to missing capability checks, altering student assessment scores.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-102584?
CVE-2026-102584 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 30 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was found in Moodle. Due to a missing capability check, a low-privileged authenticated user can trigger the recalculation of grade penalties without holding the required permissions. This issue allows unauthorized users to modify grade penalty records, potentially altering student assessment scores.
Weakness: CWE-425
Which versions are affected by CVE-2026-102584?
1 open source package ship an affected version, including moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle Bitnami | From 5.0.0 | 5.0.9, 5.1.6, 5.2.2 |
Products include Moodle Moodle.
How do I fix CVE-2026-102584?
Upgrade moodle to a fixed version for your release line: 5.0.9, 5.1.6 or 5.2.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-102584 being exploited?
There is no known exploitation of CVE-2026-102584 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2026-102584, GHSA-fqcg-5c9f-c55v, UBUNTU-CVE-2026-102584.