# CVE-2026-102585: Moodle: group validation missing when enrolling user to course

> Teachers can add users to groups in courses they lack access to due to missing group validation during enrollment.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** BIT-moodle-2026-102585, GHSA-h69r-rprv-j965, UBUNTU-CVE-2026-102585

## What is CVE-2026-102585?

CVE-2026-102585 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 30 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Moodle. When enrolling a user into a course while assigning them to a group, the application does not verify whether the selected group actually belongs to that course. An authenticated user with teacher privileges could exploit this flaw to add users to groups within courses they do not have authorization to access.

Weakness: CWE-842 (Placement of User into Incorrect Group)

## Which versions are affected by CVE-2026-102585?

1 open source package ship an affected version, including moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle` | Bitnami | From 5.1.0 | 5.1.6, 5.2.2 |

Products: Moodle Moodle.

## How do I fix CVE-2026-102585?

Upgrade moodle to a fixed version for your release line: 5.1.6 or 5.2.2.

## Is CVE-2026-102585 being exploited?

There is no known exploitation of CVE-2026-102585 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102585 and fix it if it is affected.

What it is: CVE-2026-102585 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 30 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102585 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle (Bitnami): affected from 5.1.0; fixed in 5.1.6, 5.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102585/ (Markdown: https://insights.sbomify.com/CVE-2026-102585/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102585
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102585
- OSV: https://osv.dev/vulnerability/CVE-2026-102585

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102585/
Summaries are generated and may contain mistakes; the official description above is the record.
