# CVE-2026-102586: Moodle: xss via password reset link due to insufficient username escaping

> Remote attackers can execute arbitrary scripts in victims' browsers via crafted password reset links due to insufficient username escaping.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** BIT-moodle-2026-102586, GHSA-rfv4-mv3r-qx66, UBUNTU-CVE-2026-102586

## What is CVE-2026-102586?

CVE-2026-102586 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Moodle. Insufficient sanitization of username input on the password reset page allows a remote attacker to conduct a cross-site scripting (XSS) attack. By convincing an unauthenticated user to access a specially crafted password reset link, an attacker could execute arbitrary script in the victim's browser.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-102586?

1 open source package ship an affected version, including moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle` | Bitnami | All versions | 4.5.13, 5.0.9, 5.1.6, 5.2.2 |

Products: Moodle Moodle.

## How do I fix CVE-2026-102586?

Upgrade moodle to a fixed version for your release line: 4.5.13, 5.0.9, 5.1.6 or 5.2.2.

## Is CVE-2026-102586 being exploited?

There is no known exploitation of CVE-2026-102586 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102586 and fix it if it is affected.

What it is: CVE-2026-102586 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-102586 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle (Bitnami): affected all versions; fixed in 4.5.13, 5.0.9, 5.1.6, 5.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102586/ (Markdown: https://insights.sbomify.com/CVE-2026-102586/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102586
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102586
- OSV: https://osv.dev/vulnerability/CVE-2026-102586

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102586/
Summaries are generated and may contain mistakes; the official description above is the record.
