CVE-2026-102588 Moodle: csrf in xml grade import
An attacker can trick authenticated users into modifying student grades via CSRF in Moodle's XML grade import feature.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-102588?
CVE-2026-102588 is a medium-severity vulnerability in Moodle Moodle, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
A flaw was found in Moodle. The XML grade import feature lacks proper Cross-Site Request Forgery (CSRF) token validation. By tricking an authenticated user with grade management permissions into visiting a malicious webpage, an attacker can trigger unauthorized requests on the victim's behalf. This flaw allows a remote attacker to set or overwrite student grades without authorization.
Weakness: CWE-346
Which versions are affected by CVE-2026-102588?
1 open source package ship an affected version, including moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle Bitnami | All versions | 4.5.13, 5.0.9, 5.1.6, 5.2.2 |
Products include Moodle Moodle.
How do I fix CVE-2026-102588?
Upgrade moodle to a fixed version for your release line: 4.5.13, 5.0.9, 5.1.6 or 5.2.2.
Is CVE-2026-102588 being exploited?
There is no known exploitation of CVE-2026-102588 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2026-102588, GHSA-w3pq-x3mm-4hh9, UBUNTU-CVE-2026-102588.