# CVE-2026-102588: Moodle: csrf in xml grade import

> An attacker can trick authenticated users into modifying student grades via CSRF in Moodle's XML grade import feature.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** BIT-moodle-2026-102588, GHSA-w3pq-x3mm-4hh9, UBUNTU-CVE-2026-102588

## What is CVE-2026-102588?

CVE-2026-102588 is a medium-severity vulnerability in Moodle Moodle, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Moodle. The XML grade import feature lacks proper Cross-Site Request Forgery (CSRF) token validation. By tricking an authenticated user with grade management permissions into visiting a malicious webpage, an attacker can trigger unauthorized requests on the victim's behalf. This flaw allows a remote attacker to set or overwrite student grades without authorization.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-102588?

1 open source package ship an affected version, including moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle` | Bitnami | All versions | 4.5.13, 5.0.9, 5.1.6, 5.2.2 |

Products: Moodle Moodle.

## How do I fix CVE-2026-102588?

Upgrade moodle to a fixed version for your release line: 4.5.13, 5.0.9, 5.1.6 or 5.2.2.

## Is CVE-2026-102588 being exploited?

There is no known exploitation of CVE-2026-102588 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102588 and fix it if it is affected.

What it is: CVE-2026-102588 is a medium-severity vulnerability in Moodle Moodle, published on 30 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-102588 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle (Bitnami): affected all versions; fixed in 4.5.13, 5.0.9, 5.1.6, 5.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102588/ (Markdown: https://insights.sbomify.com/CVE-2026-102588/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102588
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102588
- OSV: https://osv.dev/vulnerability/CVE-2026-102588

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102588/
Summaries are generated and may contain mistakes; the official description above is the record.
