# CVE-2026-102599: Socket.IO: Engine.IO Protocol Revision Mismatch DoS

> A malicious client can cause a Node.js process crash via a crafted Engine.IO protocol revision mismatch during transport upgrade.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 17 Oct 2026
- **Also known as:** GHSA-2gc4-cqfq-p2gv, MINI-x3vm-2xqf-rm69

## What is CVE-2026-102599?

CVE-2026-102599 is a high-severity denial of service vulnerability in socketio socket.io, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Socket.IO enables bidirectional and low-latency communication for every platform. From Engine.IO 6.6.0 until 6.6.10, a transport upgrade can independently derive an Engine.IO protocol revision from the upgrade request instead of enforcing the revision stored on the existing session. A malicious client can establish a valid session and send an upgrade request with a different or omitted EIO query parameter, attaching a transport with incompatible parser and heartbeat behavior. A crafted heartbeat packet can then trigger an uncaught exception and terminate the Node.js process, including when Engine.IO v3 compatibility is disabled because an omitted EIO value is interpreted as revision 3 on the affected path. This issue is fixed in Engine.IO 6.6.10.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-102599?

2 open source packages ship an affected version, including engine.io.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `engine.io` | npm | From 6.6.0 | 6.6.10 |
| `engine.io` | npm | From 6.6.0 | 6.6.10 |

## How do I fix CVE-2026-102599?

Upgrade engine.io to 6.6.10 or later.

## Is CVE-2026-102599 being exploited?

There is no known exploitation of CVE-2026-102599 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102599 and fix it if it is affected.

What it is: CVE-2026-102599 is a high-severity denial of service vulnerability in socketio socket.io, published on 13 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102599 in the wild and no public exploit code.

Affected packages and fixed versions:
- engine.io (npm): affected from 6.6.0; fixed in 6.6.10
- engine.io (npm): affected from 6.6.0; fixed in 6.6.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102599/ (Markdown: https://insights.sbomify.com/CVE-2026-102599/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102599
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102599
- OSV: https://osv.dev/vulnerability/CVE-2026-102599

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102599/
Summaries are generated and may contain mistakes; the official description above is the record.
