# CVE-2026-102600: Socket.IO: Prototype Pollution via Unsafe Client Session Lookup

> Attacker can crash Node.js process via prototype pollution in clustered Socket.IO deployments, causing denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-wfpm-5gcm-94cg

## What is CVE-2026-102600?

CVE-2026-102600 is a high-severity vulnerability in @socket.io cluster-engine, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Socket.IO enables bidirectional and low-latency communication for every platform. Prior to 0.1.1, @socket.io/cluster-engine uses inherited object properties when looking up attacker-controlled session IDs in clustered deployments. Special property names such as __proto__ or constructor can resolve through the object prototype chain instead of identifying an actual connected client, causing the Node.js process to crash and resulting in denial of service. Applications that do not use @socket.io/cluster-engine are not affected. This issue is fixed in version 0.1.1.

Weakness: CWE-20 (Improper Input Validation), CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-102600?

2 open source packages ship an affected version, including @socket.io/cluster-engine.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@socket.io/cluster-engine` | npm | All versions | 0.1.1 |
| `@socket.io/cluster-engine` | npm | All versions | 0.1.1 |

## How do I fix CVE-2026-102600?

Upgrade @socket.io/cluster-engine to 0.1.1 or later.

## Is CVE-2026-102600 being exploited?

There is no known exploitation of CVE-2026-102600 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102600 and fix it if it is affected.

What it is: CVE-2026-102600 is a high-severity vulnerability in @socket.io cluster-engine, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102600 in the wild and no public exploit code.

Affected packages and fixed versions:
- @socket.io/cluster-engine (npm): affected all versions; fixed in 0.1.1
- @socket.io/cluster-engine (npm): affected all versions; fixed in 0.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102600/ (Markdown: https://insights.sbomify.com/CVE-2026-102600/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102600
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102600
- OSV: https://osv.dev/vulnerability/CVE-2026-102600

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102600/
Summaries are generated and may contain mistakes; the official description above is the record.
