{"answers":{"affected":"2 open source packages ship an affected version, including league/flysystem.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102601 exists.","fix":"Upgrade league/flysystem to 3.35.3 or later.","what":"CVE-2026-102601 is a low-severity path traversal vulnerability in thephpleague flysystem, published on 29 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-102601 and fix it if it is affected.\n\nWhat it is: CVE-2026-102601 is a low-severity path traversal vulnerability in thephpleague flysystem, published on 29 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102601 exists.\n\nAffected packages and fixed versions:\n- league/flysystem (Packagist): affected all versions; fixed in 3.35.3\n- league/flysystem (Packagist): affected all versions; fixed in 3.35.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-102601/ (Markdown: https://insights.sbomify.com/CVE-2026-102601/index.md)","id":"CVE-2026-102601","markdown":"https://insights.sbomify.com/CVE-2026-102601/index.md","name":"CVE-2026-102601","record":{"aliases":["CLSA-2026-1790868478","CLSA-2026-1791742369","CLSA-2026-1791742447","DEBIAN-CVE-2026-102601","GHSA-cxf4-7mrp-vvpr","UBUNTU-CVE-2026-102601"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP file storage library","requires_auth":"low_privilege","summary":"Attackers can bypass path normalization checks using malformed UTF-8 to store files with hidden control characters, potentially spoofing terminal listings.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-150","name":"Improper Neutralization of Escape, Meta, or Control Sequences"}],"description":"Flysystem is an open source file storage library for PHP. Prior to 3.35.3, the default WhitespacePathNormalizer in src/WhitespacePathNormalizer.php used by Filesystem across adapters calls preg_match with the u modifier and treats both false and 0 as falsy. A path containing malformed UTF-8 causes PCRE to return false, so paths that also contain control characters bypass CorruptedPathDetected::forPath() in normalizePath(). Filesystem::write() can store such names and Filesystem::listContents() can return the raw ANSI escape sequences, allowing hidden or spoofed terminal file listings when an administrator displays them. This issue is fixed in version 3.35.3.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flysystem: WhitespacePathNormalizer's control-character (CorruptedPathDetected) check is bypassed by malformed UTF-8 in the path, affecting every adapter","id":"CVE-2026-102601","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Gotify: Insufficiently Protected Password Change endpoint","id":"CVE-2026-102603"},"packages":[{"ecosystem":"Packagist","fixed":["3.35.3"],"introduced":["0"],"last_affected":[],"package":"league/flysystem","purl":null,"source":"GHSA-cxf4-7mrp-vvpr"},{"ecosystem":"Packagist","fixed":["3.35.3"],"introduced":["0"],"last_affected":[],"package":"league/flysystem","purl":"pkg:composer/league/flysystem","source":"GHSA-cxf4-7mrp-vvpr"}],"prev":{"headline":"Socket.IO: Prototype Pollution via Unsafe Client Session Lookup","id":"CVE-2026-102600"},"products":["flysystem"],"published":"2026-09-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-29","vendors":["thephpleague"]},"summary":"Attackers can bypass path normalization checks using malformed UTF-8 to store files with hidden control characters, potentially spoofing terminal listings.","url":"https://insights.sbomify.com/CVE-2026-102601/"}