# CVE-2026-102607: ZoneMinder: Authenticated OS Command Injection (RCE) via Export Feature

> Authenticated attackers can execute arbitrary OS commands via crafted export parameters in ZoneMinder, requiring specific permissions and settings.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 19 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-102607, GHSA-7j62-cjxp-3cj5, UBUNTU-CVE-2026-102607

## What is CVE-2026-102607?

CVE-2026-102607 is a high-severity command injection vulnerability in zoneminder, published on 16 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ZoneMinder is a free, open source closed-circuit television software application. Prior to 1.38.3, the exportEvents() function concatenates the attacker-controlled exportFile request parameter into a shell command without neutralizing shell metacharacters when an authenticated user with View Events or View Snapshots permission submits an event export request with a crafted exportFile value, a valid CSRF token, and exportDetail enabled. The affected components are exportEvents(), exportFile, web/ajax/event.php, web/skins/classic/includes/export_functions.php. In this attack mechanism, the crafted exportFile value reaches the trailing directory argument of a tar or zip command executed by exec(). The attacker can execute arbitrary operating system commands as the web server user. This issue is fixed in version 1.38.3.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-102607?


## How do I fix CVE-2026-102607?

No fix has been published for CVE-2026-102607 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-102607 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102607 exists.

Public exploit code:

- PoC of CVE-2026-102607 ZoneMinder <= 1.38.1 (github_poc): https://github.com/d4kw1n/CVE-2026-102607-ZoneMinder

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102607 and fix it if it is affected.

What it is: CVE-2026-102607 is a high-severity command injection vulnerability in zoneminder, published on 16 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102607 exists.

Affected product: zoneminder. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102607/ (Markdown: https://insights.sbomify.com/CVE-2026-102607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102607
- OSV: https://osv.dev/vulnerability/CVE-2026-102607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102607/
Summaries are generated and may contain mistakes; the official description above is the record.
