# CVE-2026-102677: Electron: Sandboxed preload code cache can be poisoned by a compromised renderer

> A compromised renderer can poison the sandboxed preload code cache, allowing execution of arbitrary code in the privileged preload context.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2026
- **Updated:** 2 Oct 2026
- **Also known as:** GHSA-qmv3-fv6v-rmhq

## What is CVE-2026-102677?

CVE-2026-102677 is a high-severity code injection vulnerability in Electronjs Electron, published on 29 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. From 42.3.3 until 42.10.0, 43.5.0, and 44.0.0-beta.6, Electron's sandboxed preload code cache did not verify that a cached entry matched the preload it was served for. A compromised renderer could write attacker-controlled cache data and cause Electron to reuse it for a later load, executing the renderer's code in the more privileged preload context. The issue affects applications that load untrusted content. This issue is fixed in versions 42.10.0, 43.5.0, and 44.0.0-beta.6.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-102677?

6 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | From 42.3.3 | 42.10.0 |
| `electron` | npm | From 42.3.3 | 42.10.0 |
| `electron` | npm | From 43.0.0-beta.1 | 43.5.0 |
| `electron` | npm | From 43.0.0-beta.1 | 43.5.0 |
| `electron` | npm | From 44.0.0-alpha.1 | 44.0.0-beta.6 |
| `electron` | npm | From 44.0.0-alpha.1 | 44.0.0-beta.6 |

Products: Electronjs Electron.

## How do I fix CVE-2026-102677?

Upgrade electron to a fixed version for your release line: 42.10.0, 43.5.0 or 44.0.0-beta.6.

## Is CVE-2026-102677 being exploited?

There is no known exploitation of CVE-2026-102677 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102677 and fix it if it is affected.

What it is: CVE-2026-102677 is a high-severity code injection vulnerability in Electronjs Electron, published on 29 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102677 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected from 42.3.3; fixed in 42.10.0
- electron (npm): affected from 42.3.3; fixed in 42.10.0
- electron (npm): affected from 43.0.0-beta.1; fixed in 43.5.0
- electron (npm): affected from 43.0.0-beta.1; fixed in 43.5.0
- electron (npm): affected from 44.0.0-alpha.1; fixed in 44.0.0-beta.6
- electron (npm): affected from 44.0.0-alpha.1; fixed in 44.0.0-beta.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102677/ (Markdown: https://insights.sbomify.com/CVE-2026-102677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102677
- OSV: https://osv.dev/vulnerability/CVE-2026-102677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102677/
Summaries are generated and may contain mistakes; the official description above is the record.
