# CVE-2026-102692: RIOT: Potential integer overflow in nanocoap Block2 handling leading to out-of-bounds memory access

> Remote attackers can trigger integer overflows in RIOT OS CoAP handling, causing out-of-bounds memory access, denial of service, or potential code execution.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** GHSA-8365-gj33-rgpf

## What is CVE-2026-102692?

CVE-2026-102692 is a critical vulnerability in RIOT-OS RIOT, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

RIOT is an open-source microcontroller operating system designed for Internet of Things devices and other embedded systems. Prior to 2026.07, nanocoap accepts oversized CoAP Block2 option values without enforcing the 20-bit maximum block number, allowing block offset multiplication to overflow on 32-bit targets. The affected master baseline is commit aeeae69e; the verified fix is later on master and remains unreleased. The oversized value passes from coap_get_blockopt() to coap_block_slicer_init(). A remote CoAP client can send a malformed Block2 option that produces an invalid slice range and can cause out-of-bounds memory access, denial of service, or memory corruption. This vulnerability is fixed in 2026.07.

Weakness: CWE-787 (Out-of-bounds Write), CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-102692?


## How do I fix CVE-2026-102692?

No fix has been published for CVE-2026-102692 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-102692 being exploited?

There is no known exploitation of CVE-2026-102692 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102692 and fix it if it is affected.

What it is: CVE-2026-102692 is a critical vulnerability in RIOT-OS RIOT, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102692 in the wild and no public exploit code.

Affected product: RIOT-OS RIOT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102692/ (Markdown: https://insights.sbomify.com/CVE-2026-102692/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102692
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102692
- OSV: https://osv.dev/vulnerability/CVE-2026-102692

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102692/
Summaries are generated and may contain mistakes; the official description above is the record.
