# CVE-2026-102695: OmniFaces: Forged combined-resource IDs and related output/push boundaries

> Attackers can forge resource IDs to disclose Facelets source code and cause memory exhaustion in OmniFaces applications.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-fp43-vj7g-pg92

## What is CVE-2026-102695?

CVE-2026-102695 is a high-severity vulnerability in omnifaces, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OmniFaces is a utility library for Faces. In OmniFaces versions before 1.14.3, 2.7.33, 3.14.23, 4.7.12, and 5.4.2, CombinedResourceHandler accepts a structurally valid deflated and base64 encoded combined resource ID without verifying that the server issued it. A forged ID can cause unbounded decoded output, add unique reconstructed IDs to a process-lifetime cache, or combine resources other than stylesheets and scripts. Because jakarta.faces.RESOURCE_EXCLUDES is not applied by this custom resolution path, a forged ID can disclose Facelets source from the webapp resource tree or META-INF/resources. In a deployment configured with the wildcard CDN mapping, a forged ID that selects omnifaces.graphic can also cause a blind, deployment-dependent server-side fetch whose destination derives partly from the request Host header. The flaw does not provide arbitrary file read or establish arbitrary-scheme or arbitrary-destination SSRF. The shared authenticity failure permits memory exhaustion and limited resource disclosure. This issue is fixed in versions 1.14.3, 2.7.33, 3.14.23, 4.7.12, and 5.4.2.

Weakness: CWE-552 (Files or Directories Accessible to External Parties), CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification)), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-102695?

10 open source packages ship an affected version, including org.omnifaces:omnifaces.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.omnifaces:omnifaces` | Maven | All versions | 1.14.3 |
| `org.omnifaces:omnifaces` | Maven | All versions | 1.14.3 |
| `org.omnifaces:omnifaces` | Maven | From 2.0.0 | 2.7.33 |
| `org.omnifaces:omnifaces` | Maven | From 2.0.0 | 2.7.33 |
| `org.omnifaces:omnifaces` | Maven | From 3.0.0 | 3.14.23 |
| `org.omnifaces:omnifaces` | Maven | From 3.0.0 | 3.14.23 |
| `org.omnifaces:omnifaces` | Maven | From 4.0.0 | 4.7.12 |
| `org.omnifaces:omnifaces` | Maven | From 4.0.0 | 4.7.12 |
| `org.omnifaces:omnifaces` | Maven | From 5.0.0 | 5.4.2 |
| `org.omnifaces:omnifaces` | Maven | From 5.0.0 | 5.4.2 |

## How do I fix CVE-2026-102695?

Upgrade org.omnifaces:omnifaces to a fixed version for your release line: 1.14.3, 2.7.33, 3.14.23 or 4.7.12.

## Is CVE-2026-102695 being exploited?

There is no known exploitation of CVE-2026-102695 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102695 and fix it if it is affected.

What it is: CVE-2026-102695 is a high-severity vulnerability in omnifaces, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102695 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.omnifaces:omnifaces (Maven): affected all versions; fixed in 1.14.3
- org.omnifaces:omnifaces (Maven): affected all versions; fixed in 1.14.3
- org.omnifaces:omnifaces (Maven): affected from 2.0.0; fixed in 2.7.33
- org.omnifaces:omnifaces (Maven): affected from 2.0.0; fixed in 2.7.33
- org.omnifaces:omnifaces (Maven): affected from 3.0.0; fixed in 3.14.23
- org.omnifaces:omnifaces (Maven): affected from 3.0.0; fixed in 3.14.23
- org.omnifaces:omnifaces (Maven): affected from 4.0.0; fixed in 4.7.12
- org.omnifaces:omnifaces (Maven): affected from 4.0.0; fixed in 4.7.12
- org.omnifaces:omnifaces (Maven): affected from 5.0.0; fixed in 5.4.2
- org.omnifaces:omnifaces (Maven): affected from 5.0.0; fixed in 5.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102695/ (Markdown: https://insights.sbomify.com/CVE-2026-102695/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102695
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102695
- OSV: https://osv.dev/vulnerability/CVE-2026-102695

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102695/
Summaries are generated and may contain mistakes; the official description above is the record.
