{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-102731 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-102731 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-102731 is a high-severity denial of service vulnerability in Apache Directory LDAP API, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-102731 and fix it if it is affected.\n\nWhat it is: CVE-2026-102731 is a high-severity denial of service vulnerability in Apache Directory LDAP API, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-102731 in the wild and no public exploit code.\n\nAffected product: Apache Directory LDAP API. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-102731/ (Markdown: https://insights.sbomify.com/CVE-2026-102731/index.md)","id":"CVE-2026-102731","markdown":"https://insights.sbomify.com/CVE-2026-102731/index.md","name":"CVE-2026-102731","record":{"aliases":["DEBIAN-CVE-2026-102731","GHSA-h24g-pjpf-8f2m","UBUNTU-CVE-2026-102731"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"LDAP API library","requires_auth":"none","summary":"A malicious peer can cause denial of service in applications using the Apache Directory LDAP API by triggering excessive memory allocation during BER decoding.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-789","name":"Memory Allocation with Excessive Size Value"}],"description":"Memory allocation with excessive size value vulnerability in Apache Directory LDAP API.\n\nA malicious peer (or a MITM) can send a small BER-encoded response causing a large memory allocation before any data is received. This can lead to an OutOfMemoryError and denial of service.\n\nThe client JVM OOMs (OutOfMemoryError bypasses the DecoderException handlers) or pins the large allocation per connection while the attacker stalls.\n\nA handful of connections exhausts any heap. The same bytes from an unauthenticated pre-bind client hit any embedding server that did not set MAX_PDU_SIZE_ATTR.\n\nThis issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9.\n\nUsers are recommended to upgrade to version 1.2.9, which fixes the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Apache Directory LDAP API: Denial of service via excessive memory allocation in BER decode","id":"CVE-2026-102731","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"asteval sandbox escape: arbitrary native memory read/write via numpy ctypes in default asteval Interpreter","id":"CVE-2026-102734"},"packages":[],"prev":{"headline":"Memory corruption in eclipse-threadx/levelx(NAND driver)","id":"CVE-2026-102730"},"products":["Apache Directory LDAP API"],"published":"2026-10-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-05","vendors":["Apache Software Foundation"]},"summary":"A malicious peer can cause denial of service in applications using the Apache Directory LDAP API by triggering excessive memory allocation during BER decoding.","url":"https://insights.sbomify.com/CVE-2026-102731/"}