# CVE-2026-102731: Apache Directory LDAP API: Denial of service via excessive memory allocation in BER decode

> A malicious peer can cause denial of service in applications using the Apache Directory LDAP API by triggering excessive memory allocation during BER decoding.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Oct 2026
- **Updated:** 5 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-102731, GHSA-h24g-pjpf-8f2m, UBUNTU-CVE-2026-102731

## What is CVE-2026-102731?

CVE-2026-102731 is a high-severity denial of service vulnerability in Apache Directory LDAP API, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Memory allocation with excessive size value vulnerability in Apache Directory LDAP API.

A malicious peer (or a MITM) can send a small BER-encoded response causing a large memory allocation before any data is received. This can lead to an OutOfMemoryError and denial of service.

The client JVM OOMs (OutOfMemoryError bypasses the DecoderException handlers) or pins the large allocation per connection while the attacker stalls.

A handful of connections exhausts any heap. The same bytes from an unauthenticated pre-bind client hit any embedding server that did not set MAX_PDU_SIZE_ATTR.

This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9.

Users are recommended to upgrade to version 1.2.9, which fixes the issue.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-102731?


## How do I fix CVE-2026-102731?

No fix has been published for CVE-2026-102731 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-102731 being exploited?

There is no known exploitation of CVE-2026-102731 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102731 and fix it if it is affected.

What it is: CVE-2026-102731 is a high-severity denial of service vulnerability in Apache Directory LDAP API, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-102731 in the wild and no public exploit code.

Affected product: Apache Directory LDAP API. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102731/ (Markdown: https://insights.sbomify.com/CVE-2026-102731/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102731
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102731
- OSV: https://osv.dev/vulnerability/CVE-2026-102731

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102731/
Summaries are generated and may contain mistakes; the official description above is the record.
