# CVE-2026-102756: DataEase bar-horizontal Axis Label Tooltip Stored Cross-Site Scripting

> Authenticated attackers can inject JavaScript via dataset labels, executing code in victims' sessions when viewing dashboards.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** GHSA-6pfp-pqvf-xvfg

## What is CVE-2026-102756?

CVE-2026-102756 is a medium-severity cross-site scripting vulnerability in dataease, published on 14 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

DataEase is an open source data visualization and analysis tool. Prior to 2.10.26, authenticated users who can edit dataset fields and chart configuration can store an HTML-bearing dimension value in a bar-horizontal chart. When lengthLimit truncates the category axis label, configAxisLabelLengthLimit in core/core-frontend/src/views/chart/components/js/panel/common/common_antv.ts retrieves the full label and assigns it to the g2-tooltip-title element through innerHTML. A victim who opens the dashboard and hovers the truncated label can execute attacker-controlled JavaScript in the victim's DataEase session. This issue is fixed in version 2.10.26.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-102756?


## How do I fix CVE-2026-102756?

No fix has been published for CVE-2026-102756 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-102756 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102756 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102756 and fix it if it is affected.

What it is: CVE-2026-102756 is a medium-severity cross-site scripting vulnerability in dataease, published on 14 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102756 exists.

Affected product: dataease. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102756/ (Markdown: https://insights.sbomify.com/CVE-2026-102756/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102756
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102756
- OSV: https://osv.dev/vulnerability/CVE-2026-102756

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102756/
Summaries are generated and may contain mistakes; the official description above is the record.
