# CVE-2026-10281: Enderfga claw-orchestrator API Endpoint embedded-server.ts EmbeddedServer missing authentication

> Remote attackers can access the EmbeddedServer API endpoint without authentication due to missing checks in the claw-orchestrator library.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 1 Jun 2026
- **Also known as:** GHSA-q6qc-xp4q-rjq5

## What is CVE-2026-10281?

CVE-2026-10281 is a medium-severity missing authorization vulnerability in Enderfga claw-orchestrator, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A weakness has been identified in Enderfga claw-orchestrator up to 3.5.5. This affects the function EmbeddedServer of the file src/embedded-server.ts of the component API Endpoint. This manipulation causes missing authentication. The attack may be initiated remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 3.5.6 mitigates this issue. Patch name: d0b02a800aa0689d9428cc4cc170e0b6589fb2c3. The affected component should be upgraded.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-10281?

2 open source packages ship an affected version, including @enderfga/claw-orchestrator.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@enderfga/claw-orchestrator` | npm | All versions | 3.5.6 |
| `@enderfga/claw-orchestrator` | npm | All versions | 3.5.6 |

## How do I fix CVE-2026-10281?

Upgrade @enderfga/claw-orchestrator to 3.5.6 or later.

## Is CVE-2026-10281 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10281 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-10281 and fix it if it is affected.

What it is: CVE-2026-10281 is a medium-severity missing authorization vulnerability in Enderfga claw-orchestrator, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10281 exists.

Affected packages and fixed versions:
- @enderfga/claw-orchestrator (npm): affected all versions; fixed in 3.5.6
- @enderfga/claw-orchestrator (npm): affected all versions; fixed in 3.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-10281/ (Markdown: https://insights.sbomify.com/CVE-2026-10281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-10281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-10281
- OSV: https://osv.dev/vulnerability/CVE-2026-10281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-10281/
Summaries are generated and may contain mistakes; the official description above is the record.
