# CVE-2026-102821: Russh: Unbounded memory exhaustion via CHANNEL_OPEN flood during a client-stalled rekey

> An authenticated remote peer can cause memory exhaustion and crash the server by flooding channel open messages during a stalled key exchange.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-102821, GHSA-35g8-35p8-c8fw, UBUNTU-CVE-2026-102821

## What is CVE-2026-102821?

CVE-2026-102821 is a medium-severity denial of service vulnerability in Eugeny russh, published on 29 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Russh is a Rust SSH client and server library. Prior to 0.63.2, an authenticated remote peer can send SSH_MSG_KEXINIT without the required SSH_MSG_KEX_ECDH_INIT and then flood SSH_MSG_CHANNEL_OPEN messages while SessionKexState::InProgress prevents priority_receiver in russh/src/server/session.rs from being drained. The server continues processing network input and enqueues a ChannelOpenReply for each request on an unbounded channel, allowing one connection to grow memory until the process is terminated. This issue is fixed in version 0.63.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-102821?

2 open source packages ship an affected version, including russh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `russh` | crates.io | All versions | 0.63.2 |
| `russh` | crates.io | All versions | 0.63.2 |

## How do I fix CVE-2026-102821?

Upgrade russh to 0.63.2 or later.

## Is CVE-2026-102821 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102821 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102821 and fix it if it is affected.

What it is: CVE-2026-102821 is a medium-severity denial of service vulnerability in Eugeny russh, published on 29 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102821 exists.

Affected packages and fixed versions:
- russh (crates.io): affected all versions; fixed in 0.63.2
- russh (crates.io): affected all versions; fixed in 0.63.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102821/ (Markdown: https://insights.sbomify.com/CVE-2026-102821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102821
- OSV: https://osv.dev/vulnerability/CVE-2026-102821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102821/
Summaries are generated and may contain mistakes; the official description above is the record.
