{"answers":{"affected":"2 open source packages ship an affected version, including russh.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102822 exists.","fix":"Upgrade russh to 0.63.1 or later.","what":"CVE-2026-102822 is a low-severity denial of service vulnerability in Eugeny russh, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-102822 and fix it if it is affected.\n\nWhat it is: CVE-2026-102822 is a low-severity denial of service vulnerability in Eugeny russh, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102822 exists.\n\nAffected packages and fixed versions:\n- russh (crates.io): affected all versions; fixed in 0.63.1\n- russh (crates.io): affected all versions; fixed in 0.63.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-102822/ (Markdown: https://insights.sbomify.com/CVE-2026-102822/index.md)","id":"CVE-2026-102822","markdown":"https://insights.sbomify.com/CVE-2026-102822/index.md","name":"CVE-2026-102822","record":{"aliases":["DEBIAN-CVE-2026-102822","GHSA-p8qx-h547-fjw9","UBUNTU-CVE-2026-102822"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Rust SSH library","requires_auth":"none","summary":"A remote attacker can cause a denial of service in the russh library by negotiating a MAC-less connection with a MAC-requiring cipher, triggering a panic.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-129","name":"Improper Validation of Array Index"}],"description":"Russh is a Rust SSH client and server library. Prior to 0.63.1, a connection configured to permit mac=none can negotiate it with a MAC-requiring CTR or CBC block cipher because the selection logic validates needs_mac() only when MAC selection fails. A remote peer can then send a packet with a decrypted length of zero, causing russh/src/cipher/mod.rs to shrink the previously read block before indexing buffer.buffer[16..], which panics and terminates the connection task. This issue is fixed in version 0.63.1.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"russh: negotiating a MAC-requiring block cipher (CTR/CBC) with mac=none causes a slice-index-out-of-range panic","id":"CVE-2026-102822","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"russh: Client-side channel-scoped Handler callbacks fire for channel IDs the client never opened","id":"CVE-2026-102823"},"packages":[{"ecosystem":"crates.io","fixed":["0.63.1"],"introduced":["0"],"last_affected":[],"package":"russh","purl":null,"source":"GHSA-p8qx-h547-fjw9"},{"ecosystem":"crates.io","fixed":["0.63.1"],"introduced":["0"],"last_affected":[],"package":"russh","purl":"pkg:cargo/russh","source":"GHSA-p8qx-h547-fjw9"}],"prev":{"headline":"Russh: Unbounded memory exhaustion via CHANNEL_OPEN flood during a client-stalled rekey","id":"CVE-2026-102821"},"products":["russh"],"published":"2026-09-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-29","vendors":["Eugeny"]},"summary":"A remote attacker can cause a denial of service in the russh library by negotiating a MAC-less connection with a MAC-requiring cipher, triggering a panic.","url":"https://insights.sbomify.com/CVE-2026-102822/"}