# CVE-2026-102825: Russh: Configured server auth-attempt cap is not enforced in the USERAUTH_REQUEST runtime path

> An unauthenticated remote attacker can bypass configured authentication attempt limits in the Russh SSH library, enabling brute-force attacks and increasing server workload.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-102825, GHSA-g6xm-f9xp-qq35, UBUNTU-CVE-2026-102825

## What is CVE-2026-102825?

CVE-2026-102825 is a low-severity vulnerability in Eugeny russh, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Russh is a Rust SSH client and server library. Prior to 0.62.6, the USERAUTH_REQUEST path reached from server::run_stream in russh/src/server/encrypted.rs increments self.common.auth_attempts but never compares it with server::Config.max_auth_attempts. An unauthenticated remote client can continue submitting authentication requests on one connection beyond the configured cap, bypassing the deployment's attempt-limiting policy and increasing online guessing opportunity and backend authentication workload. This issue is fixed in version 0.62.6.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2026-102825?

2 open source packages ship an affected version, including russh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `russh` | crates.io | All versions | 0.62.6 |
| `russh` | crates.io | All versions | 0.62.6 |

## How do I fix CVE-2026-102825?

Upgrade russh to 0.62.6 or later.

## Is CVE-2026-102825 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102825 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102825 and fix it if it is affected.

What it is: CVE-2026-102825 is a low-severity vulnerability in Eugeny russh, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102825 exists.

Affected packages and fixed versions:
- russh (crates.io): affected all versions; fixed in 0.62.6
- russh (crates.io): affected all versions; fixed in 0.62.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102825/ (Markdown: https://insights.sbomify.com/CVE-2026-102825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102825
- OSV: https://osv.dev/vulnerability/CVE-2026-102825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102825/
Summaries are generated and may contain mistakes; the official description above is the record.
