# CVE-2026-102826: simple-git allows command execution through unblocked Git configuration includes

> Attackers can execute arbitrary commands via Git configuration includes in simple-git if applications pass untrusted custom arguments to clone operations.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** CLEANSTART-2026-OG21794, CLEANSTART-2026-UG74776, GHSA-g4wm-2vf7-vfgr, MINI-cj9q-q5vq-jq4q, MINI-fmxg-rh45-jw92, ROOT-APP-NPM-CVE-2026-102826

## What is CVE-2026-102826?

CVE-2026-102826 is a high-severity command injection vulnerability in steveukx git-js, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin does not completely reject configuration includes supplied through customArgs to git.clone(). The missing include.path classification permits Git to load an attacker-controlled configuration file, and the initial remediation does not cover includeIf.<condition>.path, allowing the same file-loading primitive through a conditional include. A loaded configuration can set an executable Git option such as core.sshCommand, which Git invokes during the clone operation with the privileges of the Node.js process. Exploitation requires the application to pass attacker-influenced custom arguments and requires an attacker-controlled file that the process can read. This issue is fixed in 4.0.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-102826?

2 open source packages ship an affected version, including simple-git. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simple-git` | npm | All versions | 4.0.0 |
| `simple-git` | npm | All versions | 4.0.0 |

Products: Simple-Git Project Simple-Git.

## How do I fix CVE-2026-102826?

Upgrade simple-git to 4.0.0 or later.

## Is CVE-2026-102826 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102826 exists.

Public exploit code:

- Offline simple-git evidence checker for CVE-2026-102826. Git configuration and package evidence. Standalone Python; JSON/CSV/HTML reports; no exploit payloads. (github_poc): https://github.com/CompleteTech-Security/simple-git-rce-check

## Other vulnerabilities in steveukx git-js

- [CVE-2026-28292](https://insights.sbomify.com/CVE-2026-28292/): simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE (critical 9.8)
- [CVE-2026-102828](https://insights.sbomify.com/CVE-2026-102828/): simple-git unsafe-operation guard does not block trailer command configuration (critical 9.2)
- [CVE-2026-6951](https://insights.sbomify.com/CVE-2026-6951/): simple-git is vulnerable to Remote Code Execution (critical 9.2)
- [CVE-2026-102827](https://insights.sbomify.com/CVE-2026-102827/): simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291) (high 8.1)
- [CVE-2026-28291](https://insights.sbomify.com/CVE-2026-28291/): simple-git has Command Execution via Option-Parsing Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102826 and fix it if it is affected.

What it is: CVE-2026-102826 is a high-severity command injection vulnerability in steveukx git-js, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-102826 exists.

Affected packages and fixed versions:
- simple-git (npm): affected all versions; fixed in 4.0.0
- simple-git (npm): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102826/ (Markdown: https://insights.sbomify.com/CVE-2026-102826/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102826
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102826
- OSV: https://osv.dev/vulnerability/CVE-2026-102826

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102826/
Summaries are generated and may contain mistakes; the official description above is the record.
