{"answers":{"affected":"2 open source packages ship an affected version, including simple-git. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-102827 in the wild and no public exploit code.","fix":"Upgrade simple-git to 4.0.0 or later.","what":"CVE-2026-102827 is a high-severity command injection vulnerability in steveukx git-js, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-102827 and fix it if it is affected.\n\nWhat it is: CVE-2026-102827 is a high-severity command injection vulnerability in steveukx git-js, published on 29 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-102827 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simple-git (npm): affected all versions; fixed in 4.0.0\n- simple-git (npm): affected all versions; fixed in 4.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-102827/ (Markdown: https://insights.sbomify.com/CVE-2026-102827/index.md)","id":"CVE-2026-102827","markdown":"https://insights.sbomify.com/CVE-2026-102827/index.md","name":"CVE-2026-102827","record":{"aliases":["CLEANSTART-2026-PO58862","CLEANSTART-2026-UW23972","CLSA-2026-1791973734","GHSA-858h-whjf-mvg5","MINI-64cw-x25m-863p","MINI-mm8q-57xg-83w4","ROOT-APP-NPM-CVE-2026-102827"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js Git library","requires_auth":"none","summary":"Attackers can bypass unsafe operation checks in simple-git using abbreviated Git options to execute arbitrary commands via push arguments.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"simple-git","vendor":"simple-git_project"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin compares parsed option names with literal dangerous option spellings while Git accepts unambiguous long-option abbreviations. Attacker-influenced push arguments such as abbreviated --receive-pack or --exec forms can therefore bypass detectVulnerableFlags, reach git push against a local or file remote or an attacker-influenced receive-pack target, and cause Git to invoke an attacker-selected command in consumers that expose those arguments. The clone-side abbreviation handling does not protect the push path. This issue is fixed in 4.0.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2026-10-13","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-10-13T15:14:39Z","kind":"github_poc","ref":"https://github.com/D7EAD/CVE-2026-102827","stars":2,"title":"Command execution and patch bypass of CVE-2026-28291 in git-js."}],"tier":"poc_unverified"},"has_fix":true,"headline":"simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -\u003e command execution (residual of CVE-2026-28291)","id":"CVE-2026-102827","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"simple-git unsafe-operation guard does not block trailer command configuration","id":"CVE-2026-102828"},"packages":[{"ecosystem":"npm","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"simple-git","purl":null,"source":"GHSA-858h-whjf-mvg5"},{"ecosystem":"npm","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"simple-git","purl":"pkg:npm/simple-git","source":"GHSA-858h-whjf-mvg5"}],"prev":{"headline":"simple-git allows command execution through unblocked Git configuration includes","id":"CVE-2026-102826"},"products":["git-js"],"published":"2026-09-29","related":[{"cvss_score":9.8,"headline":"simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE","id":"CVE-2026-28292","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":9.2,"headline":"simple-git unsafe-operation guard does not block trailer command configuration","id":"CVE-2026-102828","kev_date_added":null,"published":"2026-09-29"},{"cvss_score":9.2,"headline":"simple-git is vulnerable to Remote Code Execution","id":"CVE-2026-6951","kev_date_added":null,"published":"2026-04-25"},{"cvss_score":8.1,"headline":"simple-git allows command execution through unblocked Git configuration includes","id":"CVE-2026-102826","kev_date_added":null,"published":"2026-09-29"},{"cvss_score":8.1,"headline":"simple-git has Command Execution via Option-Parsing Bypass","id":"CVE-2026-28291","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":8.1,"headline":"Remote code execution in simple-git","id":"CVE-2022-25860","kev_date_added":null,"published":"2023-01-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-02","vendors":["steveukx"]},"summary":"Attackers can bypass unsafe operation checks in simple-git using abbreviated Git options to execute arbitrary commands via push arguments.","url":"https://insights.sbomify.com/CVE-2026-102827/"}