CVE-2026-102828 simple-git unsafe-operation guard does not block trailer command configuration

Critical 9.2 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2026-102828?

CVE-2026-102828 is a critical vulnerability in steveukx git-js, published on 29 Sep 2026.

Official description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. From 3.15.0 until 4.0.1, the default blockUnsafeOperationsPlugin does not classify trailer.<token>.cmd as unsafe configuration. An application that passes attacker-controlled values through SimpleGitOptions.config or inline -c arguments can therefore allow Git to invoke an attacker-selected shell command when git interpret-trailers processes the configured trailer. The command executes with the operating-system identity and permissions of the Node.js process. This issue is fixed in 4.0.1.

Weakness: CWE-78, CWE-184

Which versions are affected by CVE-2026-102828?

2 open source packages ship an affected version, including simple-git. It affects 1 product.

PackageAffectedFixed in
simple-git npmFrom 3.15.04.0.1
simple-git npmFrom 3.15.04.0.1

Products include Simple-Git Project Simple-Git.

How do I fix CVE-2026-102828?

Upgrade simple-git to 4.0.1 or later.

Is CVE-2026-102828 being exploited?

There is no known exploitation of CVE-2026-102828 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-FS80263, CLEANSTART-2026-MR56986, GHSA-x6jw-m9v5-85vh, MINI-cgwx-j676-fqv2, MINI-x39m-79rm-wh6w, ROOT-APP-NPM-CVE-2026-102828.

Is CVE-2026-102828 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free