{"answers":{"affected":"2 open source packages ship an affected version, including simple-git. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-102828 in the wild and no public exploit code.","fix":"Upgrade simple-git to 4.0.1 or later.","what":"CVE-2026-102828 is a critical vulnerability in steveukx git-js, published on 29 Sep 2026."},"fix_prompt":"Check this codebase for CVE-2026-102828 and fix it if it is affected.\n\nWhat it is: CVE-2026-102828 is a critical vulnerability in steveukx git-js, published on 29 Sep 2026. \nExploitation: There is no known exploitation of CVE-2026-102828 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- simple-git (npm): affected from 3.15.0; fixed in 4.0.1\n- simple-git (npm): affected from 3.15.0; fixed in 4.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-102828/ (Markdown: https://insights.sbomify.com/CVE-2026-102828/index.md)","id":"CVE-2026-102828","markdown":"https://insights.sbomify.com/CVE-2026-102828/index.md","name":"CVE-2026-102828","record":{"aliases":["CLEANSTART-2026-FS80263","CLEANSTART-2026-MR56986","GHSA-x6jw-m9v5-85vh","MINI-cgwx-j676-fqv2","MINI-x39m-79rm-wh6w","ROOT-APP-NPM-CVE-2026-102828"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"simple-git","vendor":"simple-git_project"}],"cvss":{"score":9.2,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-184","name":"Incomplete List of Disallowed Inputs"}],"description":"simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. From 3.15.0 until 4.0.1, the default blockUnsafeOperationsPlugin does not classify trailer.\u003ctoken\u003e.cmd as unsafe configuration. An application that passes attacker-controlled values through SimpleGitOptions.config or inline -c arguments can therefore allow Git to invoke an attacker-selected shell command when git interpret-trailers processes the configured trailer. The command executes with the operating-system identity and permissions of the Node.js process. This issue is fixed in 4.0.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"simple-git unsafe-operation guard does not block trailer command configuration","id":"CVE-2026-102828","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"simple-git: `VISUAL` editor environment variable is omitted from unsafe editor detection","id":"CVE-2026-102829"},"packages":[{"ecosystem":"npm","fixed":["4.0.1"],"introduced":["3.15.0"],"last_affected":[],"package":"simple-git","purl":null,"source":"GHSA-x6jw-m9v5-85vh"},{"ecosystem":"npm","fixed":["4.0.1"],"introduced":["3.15.0"],"last_affected":[],"package":"simple-git","purl":"pkg:npm/simple-git","source":"GHSA-x6jw-m9v5-85vh"}],"prev":{"headline":"simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -\u003e command execution (residual of CVE-2026-28291)","id":"CVE-2026-102827"},"products":["git-js"],"published":"2026-09-29","related":[{"cvss_score":9.8,"headline":"simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE","id":"CVE-2026-28292","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":9.2,"headline":"simple-git is vulnerable to Remote Code Execution","id":"CVE-2026-6951","kev_date_added":null,"published":"2026-04-25"},{"cvss_score":8.1,"headline":"simple-git allows command execution through unblocked Git configuration includes","id":"CVE-2026-102826","kev_date_added":null,"published":"2026-09-29"},{"cvss_score":8.1,"headline":"simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -\u003e command execution (residual of CVE-2026-28291)","id":"CVE-2026-102827","kev_date_added":null,"published":"2026-09-29"},{"cvss_score":8.1,"headline":"simple-git has Command Execution via Option-Parsing Bypass","id":"CVE-2026-28291","kev_date_added":null,"published":"2026-04-13"},{"cvss_score":8.1,"headline":"Remote code execution in simple-git","id":"CVE-2022-25860","kev_date_added":null,"published":"2023-01-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-30","vendors":["steveukx"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-102828/"}