# CVE-2026-102828: simple-git unsafe-operation guard does not block trailer command configuration


- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 29 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** CLEANSTART-2026-FS80263, CLEANSTART-2026-MR56986, GHSA-x6jw-m9v5-85vh, MINI-cgwx-j676-fqv2, MINI-x39m-79rm-wh6w, ROOT-APP-NPM-CVE-2026-102828

## What is CVE-2026-102828?

CVE-2026-102828 is a critical vulnerability in steveukx git-js, published on 29 Sep 2026. 

### Official description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. From 3.15.0 until 4.0.1, the default blockUnsafeOperationsPlugin does not classify trailer.<token>.cmd as unsafe configuration. An application that passes attacker-controlled values through SimpleGitOptions.config or inline -c arguments can therefore allow Git to invoke an attacker-selected shell command when git interpret-trailers processes the configured trailer. The command executes with the operating-system identity and permissions of the Node.js process. This issue is fixed in 4.0.1.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-102828?

2 open source packages ship an affected version, including simple-git. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simple-git` | npm | From 3.15.0 | 4.0.1 |
| `simple-git` | npm | From 3.15.0 | 4.0.1 |

Products: Simple-Git Project Simple-Git.

## How do I fix CVE-2026-102828?

Upgrade simple-git to 4.0.1 or later.

## Is CVE-2026-102828 being exploited?

There is no known exploitation of CVE-2026-102828 in the wild and no public exploit code.

## Other vulnerabilities in steveukx git-js

- [CVE-2026-28292](https://insights.sbomify.com/CVE-2026-28292/): simple-git has blockUnsafeOperationsPlugin bypass via case-insensitive protocol.allow config key that enables RCE (critical 9.8)
- [CVE-2026-6951](https://insights.sbomify.com/CVE-2026-6951/): simple-git is vulnerable to Remote Code Execution (critical 9.2)
- [CVE-2026-102826](https://insights.sbomify.com/CVE-2026-102826/): simple-git allows command execution through unblocked Git configuration includes (high 8.1)
- [CVE-2026-102827](https://insights.sbomify.com/CVE-2026-102827/): simple-git: unsafe-operations plugin bypass via git long-option abbreviation (--receive-p/--exe) -> command execution (residual of CVE-2026-28291) (high 8.1)
- [CVE-2026-28291](https://insights.sbomify.com/CVE-2026-28291/): simple-git has Command Execution via Option-Parsing Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-102828 and fix it if it is affected.

What it is: CVE-2026-102828 is a critical vulnerability in steveukx git-js, published on 29 Sep 2026. 
Exploitation: There is no known exploitation of CVE-2026-102828 in the wild and no public exploit code.

Affected packages and fixed versions:
- simple-git (npm): affected from 3.15.0; fixed in 4.0.1
- simple-git (npm): affected from 3.15.0; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-102828/ (Markdown: https://insights.sbomify.com/CVE-2026-102828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-102828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-102828
- OSV: https://osv.dev/vulnerability/CVE-2026-102828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-102828/
Summaries are generated and may contain mistakes; the official description above is the record.
